Hilfe bei OpenVPN



  • Hallo

    Ich habe:
    Zuhause einen PC, einen Server mit win Server 2012 r2 und einigen virtuellen Maschinen, und ne feste no-ip Andresse

    Für unterwegs: Ein Microsoft Surface mit win 10 pro

    So zuhause nutze ich die virtuellen Maschinen per remote Desktop und auch ein paar Netz Laufwerke die auf den server liegen
    und unterwegs will ich das auch.

    Hab hier schon mal gefragt und mir wurde openvpn empfohlen … ok nur ich bekomm das nicht hin.

    Ich hab mir von der Webseite die in pfsense angegeben wird der Windows Klienten runtergeladen und installiert auf dem surface.

    in pfsense starte ich den wizard, klicke mich da durch und gut. dann sollte ich da nen paar ca's anlegen und so nen kram wo ich nicht weis was das ist habs aber gemacht nach einer anleitung. hab das export plugin installiert und da geht nix, ganz unten bei Clients steht nichts ???

    hab weitergesucht und noch eine anleitung gefunden und noch eine und noch eine und in jeder steht immer was anderes. und wenn ich jemanden frage ... "frauen sind halt dumm"
    :'(
    ich habe ein paar Grundkenntnisse in Linux und was Netzwerke angeht auch, hab mich aber nie wirklich intensiv damit befasst, nur soweit das mein kram läuft. Ich arbeite als Einzelkämpferin im Grafikbereich, und all meine Grafiken, Texturen, Fotos (raw Format) usw. liegen auf den Server wegen der extrem hohen Daten mänge und weil ich die auf zwei PCs gleichzeitig brauch und nicht immer alles doppelt haben will. Im mom isses so, wenn ich unterwegs bin habe ich 3 4TB usb Festplatten dabei mit einer Kopie all der Daten und das ist super umständlich ...

    Ist hier jemand bereit, mir eine schritt für schritt Anleitung zu geben mit der ich an mein Ziel komme und das ohne Frauen feindlichen Anspielungen?



  • So ins Blaue geraten, wenn bei Clients im Exporter nichts steht, gibt es u.U. keine passenden User und/oder keine Client Zertifikate.
    Magst Du uns mal Screenshots von Deiner OpenVPN Serverkonfiguration, der Certificates Seite und vom User machen, der sich einloggen können soll?



  • Moin,

    wenn deine Aufzählung stimmt ist hier bereits der Fehler:
    "dann sollte ich da nen paar ca's anlegen und so nen kram wo ich nicht weis was das ist habs aber gemacht"

    Du benötigst genau eine CA und mindestens zwei Zertifikate die mit dieser CA erstellt wurden.
    Nach meiner Meinung:

    • lösche unter openvpn alle Server
    • lösche unter Cert. Manager/Certifikates alle Zertifikate bis auf das des webConfigurators
    • lösche nun die CA's

    Nun lege bitte eine neue CA an.
    Denk dir ein paar lustige Namen aus und Füll damit das Formular aus.
    Dann lege unter Certifi… EIN SERVERZERTIFIKAT für den Open VPN Server an und benenn es entsprechend.
    Wechsel nun zu den Usern.
    Hier muss es ja den Admin geben. Dieser benötigt auch ein Zertifikat, welches Du im unteren Drittel erstellen kannst.
    Nun sollte es mit CA und Zertifikaten erst einmal reichen.
    Starte nun den openVPN wiz. und setze dort die gerade erstellte CA und das Serverzertifikat ein.
    Den Rest beantwortest Du passend zu deinem Netz.
    Zum Schluss lass ihn auch die FireWall Regeln setzen (auf die Gefahr das diese nun doppelt sind)
    Jetzt solltest Du die OpenVPN config für den User Admin exportieren können.
    Nun bitte testen.

    Sorry für die Tippfehler aber ich habe dies gerade auf einem Pad geschrieben, nicht gerade toll.

    HornetX11

    Ps Frauen werden auch nicht nass den der Weg vom Schlafzimmer in die Küche ist überdacht 8)

    Du kriegst das hin!



  • OK habs zu 50% hinbekommen

    Ich kann mich verbinden und im Internet unterwegs sein und eine anfrage bei wieistmeineip.de zeigt ich nutze die IP von meinem Zuhause Anschluss

    Nur ich komm nicht ins Lokale Lan ….

    Und ich habe festgestellt, als Client IP wurde mir einmal die von meinem Server zugewiesen und einmal die einer Virtuellen Maschine
    https://gyazo.com/0ed8a5f7fa1e3937e789d66e6e8be079
    Als DHCP Server steht da auch ne ip die eine VM hat die Subnet Mask passt auch nicht :(

    Wo stell ich das ein? vorallem kann ich da nen IP Pool angeben der genutzt werden darf?

    Und wie gehe ich da vor, wenn ich nen 2. nutzer hinzufügen will?



  • Moin,

    Hat es einen Grund das Du auf Layer 2 bridged?
    Normal ist hier eigentlich ein tun Layer 3 device mit routing.

    Aber ohne weitere Infos über dein Netz ist das alles recht mühsam.

    HornetX11



  • Moin,

    den zusätzlichen User legst Du unter System/User an und verpasst Ihm genau wie dem Admin ein Zertifikat. Rest ist gleich.

    Schau Mai in deine PM