Get Error: [object XMLHttpRequest] on my PC browser



  • *** This issue is not  caused by pfsense upgrade to 2.3.3. It is something to do with my PC but I am hoping someone can help me figure it out.  Please read for more details  ***

    After I upgraded to 2.3.3, I get this error "Error: [object XMLHttpRequest]" on the Traffic Graphs widget (on dashboard). It does not happen right away but 100% re-createable if  I leave the dashboard page up for a while. I have tried Chrome/FF/IE (win 10 machine) and the I get the same error, at the same time for all 3 browsers running simultaneously.  I do not get the error if I go directly to Traffic graphs via Status–>Traffic Graphs

    However, I do not believe this is a pfsense error. I have tried on another 2x win 10 machine and a windows 7 machine and I do not get the error for the same pfsense box.

    Does anyone know how to fix this or if i can remove/re-install something in the background.

    Thanks in advance



  • I am seeing this as well in the traffic graphs.  Restarting PHP-FPM fixes it for awhile.  Out of the 4 firewalls I manage, 2 are i386 builds and are the only ones experiencing this.

    2.3.3-RELEASE (i386)
    built on Thu Feb 16 06:59:50 CST 2017
    FreeBSD 10.3-RELEASE-p16

    Intel(R) Atom(TM) CPU D2500 @ 1.86GHz
    2 CPUs: 1 package(s) x 2 core(s)

    -Dan



  • I remember noticing that pfSense has done this ever since the 2.2.x->2.3.x update on i386 builds as well. It used to give certificate error messages but now it just breaks :) I've tested with windows 7 with IE11.

    EDIT: Just got the certificate error, and now the traffic graph doesn't display with the error message.



  • Its annoying and i also noticed after going to  2.3.3 last month. I tried the restart PHP-FPM from console and still get the error.

    Please post if you find a fix.



  • Just to bump this, I noticed that every nanobsd upgrade on pfSense has been plagued with the "/etc/rc.conf_mount_rw" issue. I thought nanobsd was always set to read-write, but I cant upgrade without setting /etc/rc.conf_mount_rw from the shell.


Log in to reply