Ipcad не видит vlan интерфейсы [решено]



  • Всем привет. Столкнулся с сабж.
    Вроде что то работает если указать в конфиге:

    interface re1 filter "ip and dst net 10.14.0.0/24 and not src net 10.14.
    0.0/24 and not src port 80";
    interface re1 filter "ip and dst net 10.14.2.0/24 and not src net 10.14.
    2.0/24 and not src port 80";

    вот только интерфейсы у меня
    re1_vlan100
    re1_vlan200
    и если их записываю так то ругается что есть ошибка в конфиге (в строке 118), а если указываю как opt1 и opt2, то rsh stat показывает что трафик не идет и все интерфейсы в состоянии down.
    Как жить?

    p.s. в данный момент такая картина (я так понимаю это плохая картина):

    Interface re1: received 95163, 5 m average 0 bytes/sec, 0 pkts/sec, dropped 0
    Interface re1: received 95169, 5 m average 0 bytes/sec, 0 pkts/sec, dropped 0
    Interface re1: received 95174, 5 m average 0 bytes/sec, 0 pkts/sec, dropped 0
    Interface re1: received 95181, 5 m average 0 bytes/sec, 0 pkts/sec, dropped 0
    Interface re1: received 95183, 5 m average 0 bytes/sec, 0 pkts/sec, dropped 0
    Flow entries made: 0
    Memory usage: 0% (0 from 10485760)
    Free slots for rsh clients: 9
    IPCAD uptime is 6 minutes

    p.p.s. строка 118:

    interface re1 filter "ip and dst net 10.14.0.0/24 and not src net 10.14.0.0/24 a
    nd not src port 80";
    interface re1 filter "ip and dst net 10.14.2.0/24 and not src net 10.14.2.0/24 a
    nd not src port 80";

    ошибка возникает когда название интерфейсов меняется на re1_vlan100 и re1_vlan200



  • Вообщем попытки пропатчить ipcad ни к чему не привели но удалось переименовать один интерфейс как re1_300 и ipcad нормально запустился.
    Меняем имя vlanif в viconfig далее выполняем ifconfig re1_vlan300 name re1_300.