Pfsense & build in Wi-Fi: no internet



  • Hello,

    I have an APU2 with additional build in Wi-Fi-Card. I am at the point where I can successfully connect to the Access Point from a Client device. Unfortunately it is not yet possible to connect to the internet.

    I found a tutorial from 2015 (https://blog.artooro.com/2015/02/20/how-to-configure-wi-fi-in-pfsense/) where the writer adds a bridge to get things going.

    I want to ask if this is still necessary or if there is a more common solution for this?

    I have only one LAN-Port in use, one is free. Would it also be possible to bridge to the unused port?

    Thanks in advance,

    Af0x



  • I answer myself: yes, it is necessary.


  • Netgate Administrator

    You only need to add a bridge if you need the wifi devices to be in the same subnet as the wired interface it's bridged to.

    To simply add the wifi interface and make it available as an access point for clients a bridge is not necessary.

    Steve



  • ok, thanks. why didn´t I have internet then? do i have to give the wifi its own subnet to make this work? I configured it as "IPv4 Configuration Type: none" so it could not work, right?


  • Netgate Administrator

    Indeed if you're configuring it as a separate interface you have to give it a subnet and set the interface to a static IP in that subnet.

    You will also probably want to enable DHCP on the new interface and add firewall rules to allow traffic from wifi clients to reach the internet.

    Steve



  • As I am a noob on pfsense I am interested how the firewall rule should look like to allow clients internet access.

    Currently I am going with the bridge-solution. But maybe in the future someone (including me) wants to know how to do it.


  • Netgate Administrator

    Personally I like to configure the rules as shown in the attached screenshot.

    Some people prefer not to use the inverted match ! (not) rule as it can appear confusing.

    Steve

    ![wifi rules.png](/public/imported_attachments/1/wifi rules.png)
    ![wifi rules.png_thumb](/public/imported_attachments/1/wifi rules.png_thumb)