Pfsense 2.3.3 hyperv Ovh



  • Hi

    I test to install pfsense on a hyper v  virtual machine on a OVH dedicated server

    I configure my 2 network card one for wan and the other for my vrack .
    I test to ping google from my console it's ok .

    I need to remote configure pfsense .

    I create a wan rules to enable remote acces for port 443. I enable logguing for this rules.
    On my lan network i have no problem to connect to web configurator
    When I test to remotly  connect to web configurator I have an error the page can't be displayed.
    When I look in status/system logs/firewall I can see a line with a green check but I can't connect

    Mar 7 17:54:48 WAN Remote admin (1488406995)   109.xxx.xx.xx3:53280   51.xxx.xxx.142:443 TCP:S

    can you tell me wath is my error?

    Best Regards

    Lolo



  • So.. since you get the log entry, that means you definitely reach your pfSense? A hyper-v incoming networking misconfiguration is impossible then?

    Since, it looks like you did do everything correctly, at least here only the firewall rule is mentioned https://doc.pfsense.org/index.php/How_can_I_access_the_webGUI_from_the_WAN .

    As for me, when accessing the UI, I always do it via LAN, and if external, I use VPN LAN via OpenVPN. That is more cumbersome of course if you only want the web ui.



  • Hi

    Yes i can acces to my pfsense from my lan.
    and from console i can ping google.com so for me my hyperv network config is ok no?

    I test to acces web configurator from wan because all the rules that i test to create don't work. ( exemple : I test to redirect one port from wan to lan server but it dont work )

    i create this rules to acces web configurator from wan:
    Protocol             Source         Port Destination Port           Gateway Queue Schedule Description

    IPv4 TCP xxx.xxx.xxx.xxx   * WAN address 443 (HTTPS) * none                 Remote admin

    An idea?

    Lolo



  • Stupid question from me -

    When accessing pfsense from the LAN are you using HTTP or HTTPS?

    pgk



  • Hi

    I use https from lan

    For Wan I test with http or https but it don't work

    Lolo



  • I test to access web configurator from wan because all the rules that i test to create don't work. ( exemple : I test to redirect one port from wan to lan server but it dont work )



  • I am running 5 dedicated servers all with virtual pfsense with hyper-v in OVH.  Did you buy a second IP?  Did you set the MAC address correctly on the pfsense virtual wan interface?  Did you add the commands to have the additional routes added to startup of pfsense?


Log in to reply