Navegacion lenta al activar Squidguard



  • Buenas tardes.
    Actualmente tengo instalado PfSense 2.3.3-RELEASE (i386).
    Instale los paquetes de Squid y SquidGuard con filtro por blacklist (Shallalist).
    Tambien instale Pf2Ad, para poder filtrar por grupo de usuarios de AD.
    La autenticacion esta funcionando bien, y el filtrado tambien, el problema es que la navegacion es demasiado lenta si squidguard esta activo.
    Al desactivarlo navega bien.
    He leido muchas paginas y he hecho algunas modificaciones en el /boot/loader.conf

    
    kern.ipc.nmbclusters=32768
    kern.maxfiles=65536
    kern.maxfilesperproc=32768
    net.inet.ip.portrange.last=65535
    
    

    No note diferencia.
    tambien aumente los redirectors (ya que vi una advertencia en el logs que me indicaba que todos estaban ocupados) con la siguiente linea en el custom integrations del gui

    
    edirect_children 70;url_rewrite_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0
    
    

    Aclaro que la opcion url_rewrite_children 16, la setee en 70, pero me la cambia sola a 16.

    Alguna linea que pueda seguir?
    Al desactivar squidguard todo va bien.
    Al activarlo, la navegacion se pone lerda.

    Agradezco de antemano y quedo a la espera de sus comentarios.
    Saludos.



  • y el consumo de cpu y memoria como va en donde tienes instalado pfSense.



  • Con el consumo bien, el cpu siempre abajo de 10, y memoria 30 máximo… Le solucionar la velocidad de navegación al instalar la última versión del paquete squid. Al instalarlo salió navegando bien, con el problema de que no puedo hacer filtro por usuario con autenticaciom "winbind ntlm" como venía haciendo, ya que al querer correr el script de pf2ad, me da un error.
    La opción de samba3 aparece y esta configurará, pero no aparece la opción de autenticacion anterior.
    Si se les ocurre algo estoy a la escucha.
    Tampoco se si la solución a la velocidad de navegación se debe al paquete squid en su o a alguna configuración que cambio al reconfigurar.



  • Estimado gremling, me está pasando casi lo mismo que el caso que estás presentando.
    Tengo instalado Pfsense 2.3.2 con squid + squidguard, con un enlace de 30Mb pero la navegación está sumamente lenta. Cuando tiro un test de velocidad, me marca entre 8 y 15 Mb.
    Quisiera preguntarte cómo hacés para desactivar el Squidguard. Si apago el servicio, al instante lo levanta, entonces para desactivarlo hay que hacerlo en Services -> Squid Guard Proxy Filter y luego clickear en "Enable SquidGuard"? ¿Pierdo la configuración al hacer esto?
    Quiero probar primero si desactivando esta opción la navegación funcionaría más rápida.
    Por otro lado, en dónde veo algún Log que pueda darme información sobre algún error o algo?
    Muchas gracais!



  • dbarraud, exactamente, desactivalo como indicas, no se pierde la configuracion, solo deja de andar el filtro hasta que lo vuelvas a activar.
    En cuanto a los logs, a mi me sirvio ver los system logs en la pestaña "Status->System llogs" y el "Real time" que aparece en "Services->Squid proxy server".
    En el primero vi errores por ejemplo, de cuando no me iniciaba el servicio de squid, y pude solucionar ese problema.
    En el segundo caso, vi el error de los redirectors, que me indicaba que estaban todos ocupados.

    Saludos.