Port-Weiterleitung an LAN-IP



  • Hallo,

    ich möchte eigentlich etwas ganz einfaches:

    Ich habe eine virtuelle pfSense, die hat über das WAN-Interface Zugang zum Internet.

    Über das LAN-Interface kann ich meinen Server erreichen (z.B. via Ping).

    Nun möchte ich den interen Server über Port 80 aus dem Internet erreichen.

    Was ist zu tun?

    Ein Portforwarding habe ich schon eingerichtet, eine PASS-Rule ebenfalls. Nur vermutlich nicht richtig.

    Port Forward:

    Interface: WAN
    Protocol: TCP
    Source Address: ANY
    Source Ports: ANY
    Dest. Address: WAN address
    Dest. Ports: 80
    NAT IP: 10.15.52.13 (das ist die LAN-IP des Servers)
    NAT Ports: 80

    PASS-Rule:

    Protocol: IPv4 TCP
    Source: Any
    Port: Any
    Destination: 10.15.52.13 (die LAN-IP des Servers)
    Port: 80

    Wo liegt der Fehler?



  • Moin,

    hast du die Regel selbst angelegt oder automatisch anlegen lassen?

    Die pfSense hat direkten Zugang zum Internet oder hängt sie irgendwo hinter einem anderen Router?


  • Moderator

    Hi,

    Wo liegt der Fehler?

    Du hast selbst eine Regel angelegt :P
    Nein im Ernst, bei einem Port Forwarding ist das nicht zwingend nötig und sogar einfacher du machst es nicht.

    Einfach den Forward anlegen wie du es gemacht hast und die Regel im Dropdown automatisch verknüpfen lassen. Dann passt das schonmal.
    Ansonsten sieht deine NAT Regel korrekt aus, da wären dann eher die Folgefragen ein Thema wie: Hat der Server auch die pfSense als Gateway, ist die von außen überhaupt transparent erreichbar etc. so wie hilfi schon schreibt.

    Gruß



  • Hi,

    ja, ich komme vom internen Server über die pfSense ins Internet, die pfSense ist als Gateway eingetragen.

    Da steckt aber noch ein zentrales Gateway des RZ-Providers davor, dass ist dem WAN-Interface aber bekannt. Ich kann von der pfSense sowohl ins Internet als auch ins LAN pingen.

    Die Regeln hatte ich anschließend schon als linked rule anlegen lassen, ändert aber nichts. Ich hänge mal 2 Screenshots an.

    Michael

    ![2017-03-08 13_25_53-Port-Forward.png_thumb](/public/imported_attachments/1/2017-03-08 13_25_53-Port-Forward.png_thumb)
    ![2017-03-08 13_26_33-Rules.png](/public/imported_attachments/1/2017-03-08 13_26_33-Rules.png)
    ![2017-03-08 13_26_33-Rules.png_thumb](/public/imported_attachments/1/2017-03-08 13_26_33-Rules.png_thumb)
    ![2017-03-08 13_25_53-Port-Forward.png](/public/imported_attachments/1/2017-03-08 13_25_53-Port-Forward.png)



  • hast du am WAN der pfSense eine öffentliche IP bzw. leitest du vom andere GW alles an die pfSense weiter?



  • Das müsste ich mit dem Provider klären, ich vermute es wird alles an die WAN-IP der pfSense weitergeleitet.

    Michael



  • hast du denn eine öffentliche IP am WAN Interface?



  • Diese Frage kannst du schon selbst klären. Du hast RFC 1918 Adressen am WAN geblockt. Fällt deine WAN IP da rein?? Das könnte die Ursache für dein Problem sein.

    Ansonsten versichere dich, dass die Server-Firewall nicht die Zugriffe blockt.

    Du kannst auch Packet Capture vom Diagnostic Menü einsetzen, um zu sehen, welche Pakete an welchem pfSense Interface ankommen und rausgehen.