Wireless stops working and pfsense freezes



  • Hello all,
    i bought an Mikrotik R52H mini PCI yesterday (Atheros AR5414) and installed it in my Thecus mini-PC. The card was recognized by pfsense (1.2.1) and i set it to AP mode with WPA encryption bridged to LAN. Everything went well until i decided to connect with a laptop. I got an IP from DHCP, was browsing for 5 seconds then my connection dropped. There was no response from pfsense even on my desktop PC with a cable, switched VGA cable and keyboard to pfsense box but only the startup menu on the display, no response to my commands from the keyboard also - totally frozen. Then i restarted pfsense and it was working for 1 minute again. Disabled the wireless interface after this…
    Does anyone have an idea what may cause this behaviour?



  • P.S. forgot to mention that there is nothing in syslog or the other logs….



  • SOLVED: it seems that all mini-pci wireless adapters are evolving a lot of heat. Unfortunately my baseboard design is not very good and the mini-pci wifi stays on top of the chipset. The chipset gets overheated and OS crashes….Disabled the wifi for now.



  • Im having the same symptoms, but am slow to accept over heating. My pfsense box is PIII atx case.

    The atheros wifi is mini-pci on a mini-pci to pci adapter.
    PFS is 1.2.1

    Everything works fine if the wireless ap (opt1) is on its own network and no bridge, but when i bridge to LAN PFS freezes in ~2min. On restart it works again… for ~2min, just long enough to remove the bridge to avoid further freezing. I have tried this several times - bridgeing opt1 with lan freezes PFS.

    By freezing, i can not ssh, ping, or load the web gui.

    At my home, I want WLAN to have the same services (not just DHCP, but zeroconf, RDP, SSH... everything.) Do I misunderstand the purpose of the bridge?

    thanks, tom



  • Wifi and shared IRQ is usually a very bad combo. Can you try to move the card around in different slots ?



  • works great as ap. just a problem when i bridge. to my lack of experience this hints away from a irq…. am i wrong...?
    tom



  • My wifi works for days in bridge mode, but eventualy no wireless clients can connect, stuck at authentication. When I don't use the bridge everything keeps working fine.


Locked