Kernel panic after OpenVPN? (SOLVED)



  • Hi,
    I was wondering if someone else has experience the same issue? im running pfSense 2.2.6 on hyper V, so far everything was running smooth. I wanted to install OpenVPN which i have done in the past with no issue, but apparently when i try to connect it gives a kernel panic and pfSense reboots itself showing this error log? any ideas?

    Thank you

    http://pastebin.com/JKXpLK4Y



  • so i ran again the test and for sure its something odd with openvpn see pictures
















  • You should upgrade to 2.3.3 & see if the issue is still there



  • I think the kernel panic is caused by this issue:

    calcru: runtime went backwards from 7 usec to 3 usec for pid 0 (kernel)
    

    Upgrading would be a good advice at any case.

    Maybe it also helps to add the line

    hint.acpi.0.disabled="1"
    

    to /boot/loader.conf.local



  • Thanks for the replies but unfortunately cannot upgrade as this is a production firewall as i have implemented WPAD and use sarg and for now i have not tested 2.3.X
    What bugs me is that i have this same setup in my test environment and works flawless.

    as viragomann says adding

    hint.acpi.0.disabled="1"
    

    i see only in /boot/loader.conf and inside it I have

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    comconsole_speed="115200"
    hw.usb.no_pf="1"
    
    

    Thank you



  • @killmasta93:

    i see only in /boot/loader.conf

    So write /boot/loader.conf.local

    You may also add it to loader.conf, but I'm not shure if it is overwritten at reboot or at updating pfSense.



  • So write /boot/loader.conf.local

    You may also add it to loader.conf, but I'm not shure if it is overwritten at reboot or at updating pfSense.

    so i added the config but then when pfsense reboot i get then this

    panic: running without device atpic requires a local apic
    

    had to revert to snapshot before



  • Disabling ACPI is a very dumb idea on modern hardware. Whatever the problem is for you it's almost certain that disabling ACPI is not going to solve it.



  • I'd tested this in a virtualized pfSense and got the same issue. In older versions deactivating ACPI was no problem and could be a workaround in such situations.

    The "calcru: runtime went backwards" issue seems to be widespread on HyperV. Maybe you can find a solution when searching in the board.



  • well i just ended up reinstalling pfSense again from scratch  and its working the OpenVPN its just odd this happened

    Thanks again


Log in to reply