Pfsense, белый IP, домены, https из локальной сети



  • Всем привет!
    Дано:

    • pfsense, две сетевухи, NAT, инет + локалка, статический белый ip_ провайдера, сеть с инетом подымается динамическими настройками
    • 192.168.50.50 - nginx сервер, на него проброшены 80 и 443 из pfsense, а так же настроил виртуальные хосты и папки натравлены на:
    • 192.168.50.51 - всякие web сервисы (nginx нужен для заворачивания всего в https)
    • есть домен domen.com, покупал у nic.ru, DNS'ы местные, домен привязан к ip_провайдера
    • в админконсоли nic есть запись resurs.fff.domen.com. A ip_провайдера
    • в nginx (192.168.50.50) настроен виртуальный сайт, который ссылается на 192.168.50.51:9999 с перенаправлением 80 порта на 443, с настройкой ssl от letsencrypt - всё это работает, но ТОЛЬКО снаружи локалки

    В браузере локалки набираю https://resurs.fff.domen.com и нифига не работает, страница не найдена.
    Хочу чтобы из локалки https://resurs.fff.domen.com открывался так же как снаружи.
    Как сделать?

    Благодарю за внимание!



  • Смотрим в сторону    System / Advanced / Firewall & NAT  конкретно NAT Reflection mode for port forwards

    Также открываем вкаждом правиле NAT Forward а именно в    Firewall / NATPort Forward / Edit фишку NAT reflection

    Где то так примерно .



  • В настройках DNS forwader или Resolver пропишите отдельные записи для ваших доменов.



  • PbIXTOP, благодарю за наводку.
    Решение:
    Services / DNS Forwarder, раздел Host Overrides кнопка Добавить.

    Работает!!!

    PS: Заголовок сформулировал неудачно. Как правильно не знаю.
    Вопрос закрыт.



  • После обновления до 2.3.4 фича перестала работать. Хром по адресу resurs.fff.domen.com пишет страница ненайдена.
    Из локалки ping resurs.fff.domen.com уходит на wan. До обновления пинг уходил на 192.168.50.50.
    Подскажите в какую сторону рыть?



  • Не переключилась ли служба DNS с forvarder на resolver?



  • В Services/DNS Resolver галка снята.
    В DNS Forvarder включена.
    Вроде не переключилась



  • Как вариант - обновление сломало этот функционал.
    Попробуйте переключиться на DNS Resolver и задействовать Host Override в нем.


Log in to reply