NTP "No active peers available"



  • Hallo,

    ich habe zwei pfsens Router im Einsatz, identische NTP Einstellungen in München und Stuttgart.
    Der Router in Stuttgart hat unt NTP immer "No active peers available".

    Wo liegt mein Problem?

    Danke ;)



  • Moin,

    welches Release ist den auf dem Router drauf?
    Wie sind deine Einstellung im NTP?
    Bekommst du in den SYSLOG's weitere Meldungen dazu?

    Gruß Sebastian



  • 2.3.3-RELEASE-p1 (amd64)

    
    Mar 19 18:38:16	ntpd	47553	192.53.103.104 8011 81 mobilize assoc 23388
    Mar 19 18:38:16	ntpd	47553	DNS ptbtime2.ptb.de -> 192.53.103.104
    Mar 19 18:38:16	ntpd	47553	193.141.27.6 8011 81 mobilize assoc 23387
    Mar 19 18:38:16	ntpd	47553	DNS 0.pfsense.pool.ntp.org -> 193.141.27.6
    Mar 19 18:38:16	ntpd	47553	0.0.0.0 c016 06 restart
    Mar 19 18:38:16	ntpd	47553	0.0.0.0 c012 02 freq_set kernel 19.326 PPM
    Mar 19 18:38:16	ntpd	47553	0.0.0.0 c01d 0d kern kernel time sync enabled
    Mar 19 18:38:16	ntpd	47553	mlockall(): Cannot allocate memory
    Mar 19 18:38:16	ntpd	47553	131.188.1.31 8011 81 mobilize assoc 23386
    Mar 19 18:38:16	ntpd	47553	129.69.1.153 8011 81 mobilize assoc 23385
    Mar 19 18:38:16	ntpd	47553	176.9.102.215 8011 81 mobilize assoc 23384
    Mar 19 18:38:16	ntpd	47553	Listening on routing socket on fd #36 for interface updates
    Mar 19 18:38:16	ntpd	47553	Listen normally on 15 lo0 [::1]:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 14 lo0 127.0.0.1:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 13 em5 172.29.168.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 12 em5 [fe80::290:bff:fe43:3569%6]:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 11 em4 172.29.170.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 10 em4 [fe80::290:bff:fe43:3568%5]:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 9 em3 172.29.172.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 8 em3 [fe80::290:bff:fe43:3567%4]:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 7 em2 192.168.25.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 6 em2 192.168.2.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 5 em2 172.29.134.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 4 em2 172.29.124.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 3 em2 172.29.174.10:123
    Mar 19 18:38:16	ntpd	47553	Listen normally on 2 em2 [fe80::290:bff:fe43:3566%3]:123
    Mar 19 18:38:16	ntpd	47553	Listen and drop on 1 v4wildcard 0.0.0.0:123
    Mar 19 18:38:16	ntpd	47553	Listen and drop on 0 v6wildcard [::]:123
    Mar 19 18:38:16	ntpd	47553	proto: precision = 0.350 usec (-21)
    Mar 19 18:38:16	ntpd	47478	Command line: /usr/local/sbin/ntpd -g -c /var/etc/ntpd.conf -p /var/run/ntpd.pid
    Mar 19 18:38:16	ntpd	47478	ntpd 4.2.8p9@1.3265-o Sat Feb 11 03:58:47 UTC 2017 (1): Starting
    Mar 19 18:38:16	ntpd	41769	0.0.0.0 c01d 0d kern kernel time sync disabled
    Mar 19 18:38:16	ntpd	41769	192.53.103.104 local addr 192.168.25.10 -> <null>Mar 19 18:38:16	ntpd	41769	192.53.103.104 8022 82 demobilize assoc 7881
    Mar 19 18:38:16	ntpd	41769	82.165.77.22 local addr 192.168.25.10 -> <null>Mar 19 18:38:16	ntpd	41769	82.165.77.22 8022 82 demobilize assoc 7880
    Mar 19 18:38:16	ntpd	41769	131.188.1.31 local addr 192.168.25.10 -> <null>Mar 19 18:38:16	ntpd	41769	131.188.1.31 8022 82 demobilize assoc 7879
    Mar 19 18:38:16	ntpd	41769	129.69.1.153 local addr 192.168.25.10 -> <null>Mar 19 18:38:16	ntpd	41769	129.69.1.153 8022 82 demobilize assoc 7878
    Mar 19 18:38:16	ntpd	41769	176.9.102.215 local addr 192.168.25.10 -> <null>Mar 19 18:38:16	ntpd	41769	176.9.102.215 8022 82 demobilize assoc 7877</null></null></null></null></null> 
    




  • Hat noch jemand eine Idee??? :-[



  • Du lässt ja nur einen Quell-NTP-Server zu: 176.9.102.215
    Und dieser ist über das Interface mit der IP 192.168.25.10 zu erreichen?
    Eine private WAN-IP oder irgendeine Netzwerkmaske falsch gesetzt?

    Wenn das alles okay ist, erreichst du den Server möglicherweise nicht wegen einer falschen Route beim ISP. Der Server antwortet brav auf Pings, daher kannst du ihn anpingen oder auch ein traceroute auf ihn loslassen.



  • Hallo,

    die 192.168.25.x ist eine Virtuelle IP die ich mal für Netzwerkfähige Ladegeräte eingerichtet habe. (Gateway 192.168.25.10)

    Die ich richtige IP ist 172.29.174.x, Gateway 172.29.174.10. Von dieser Range kann ich alle NTP`s pingen.

    Wieso nimmt die pfsense  das Virtuelle Gateway?



  • Überprüfe mal das Outbound NAT.
    Alles was am WAN rausgeht von Source 127.0.0.0/8 sollte auf die WAN Adresse umgesetzt werden. Ist das bei dir anders?



  • siehe Bild




  • Ist ja ein Graus!  :o
    Deine pfSense geht auf 3 verschiedenen Interfaces raus?
    Und vermutlich hast du zumindest 2 WAN, oder?

    Um hier weiter zu kommen, wäre interessant, wie die Interfaces konfiguriert sind, IP + Netzwerkmaske, und wie die Routen auf der pfSense aussehen.



  • Also ich habe 2 WAN Interfaces.

    1x Telekom mit fester IP
    1x Kabel BW mit fester IP

    Das 168 Interface ist ein internes, das ich erstmal disenable gesetzt habe.

    Telekom Interface:
    IPv4 Address
    xxx.xxx.xxx.176
    Subnet mask IPv4
    255.255.255.255
    Gateway IPv4
    xxx.xxx.xxx.216

    Kabel BW Interface:
    IPv4 Address
    xxx.xxx.xxx.126
    Subnet mask IPv4
    255.255.255.192
    Gateway IPv4
    xxx.xxx.xxx.65



  • Und wie sieht die Route zum NTP Server 176.9.102.215 aus?

    Wenn du die Interface Konfiguration verschleierst, kann dir hier eh schlecht geholfen werden.
    Du kannst aber selbst ein Traceroute auf 176.9.102.215 ausführen und sehen, welchen Weg die Route nehmen möchte.
    Geht ein Ping auf den Server?



  • von meinem PC (172.29.174.130):

    tracert 176.9.102.215

    Routenverfolgung zu uruz.org [176.9.102.215]
    über maximal 30 Hops:

    1  270 ms    <1 ms    <1 ms  pfSense.beilfuss.de [172.29.174.10]
      2    26 ms    26 ms    26 ms  217.0.117.216
      3    28 ms    28 ms    28 ms  217.237.154.154
      4    31 ms    30 ms    30 ms  f-ed6-i.F.DE.NET.DTAG.DE [62.156.131.234]
      5    30 ms    30 ms    30 ms  ae15-0.fra10.core-backbone.com [87.190.233.2]
      6    31 ms    31 ms    31 ms  ae10-2021.fra20.core-backbone.com [80.255.14.6]
      7    30 ms    30 ms    30 ms  core-backbone-100g-fra.hetzner.de [80.255.15.122]
      8    30 ms    31 ms    31 ms  core1.fra.hetzner.com [213.239.245.9]
      9    35 ms    35 ms    35 ms  core21.fsn1.hetzner.com [213.239.245.217]
    10    34 ms    37 ms    35 ms  ex9k2.rz15.hetzner.de [213.239.229.82]
    11    35 ms    35 ms    35 ms  uruz.org [176.9.102.215]

    Ablaufverfolgung beendet.

    von der Pfsense (localhost):

    1  217.0.117.216  25.494 ms  25.151 ms  25.181 ms
    2  217.237.154.154  24.962 ms  27.756 ms  28.163 ms
    3  62.156.131.234  29.482 ms  29.444 ms  29.531 ms
    4  87.190.233.2  29.681 ms  29.726 ms  29.470 ms
    5  80.255.14.6  30.219 ms  30.207 ms  29.743 ms
    6  80.255.15.122  29.983 ms  29.475 ms  29.727 ms
    7  213.239.245.9  29.714 ms
        213.239.245.2  31.472 ms  31.709 ms
    8  213.239.245.217  34.216 ms
        213.239.245.17  35.222 ms
        213.239.245.13  34.216 ms
    9  213.239.229.86  34.451 ms  34.710 ms  35.232 ms
    10  176.9.102.215  34.759 ms  34.682 ms  34.487 ms

    Wie kann ich die Interfacekonfiguration über Putty ausdrucken?



  • Die Routen scheinen in Ordnung zu sein.

    Irritiert hat mich die interne Quell-IP im Log, das passt aber nicht mit den Routen zusammen.
    Bei mir ist die interne Quell-IP normal, weil ich nur interne NTP-Server verwende. Ich habe das zum Test nun kurz umgestellt auf 176.9.102.215. > Gleiche Erscheinung als Quelle wird die interne IP angezeigt und der Sync funktioniert nicht.
    Das klappte erst, nachdem ich in der Service-Konfig das WAN Interface mit aufgenommen habe. Ich hatte die Info da auch so verstanden gehabt, als dass diese Interfaces nur jene sind, auf welchen der pfSense-interne NTP seinerseits abfragen beantwortet.

    Demnach müssten diese Interfaces auf deinem funktionierenden Server aber anders konfiguriert sein.

    Grüße



  • Hallo,

    meine andere pfsense hatt einen alten T-Online DSL-Anschluss. Ich habe auf der pfsene einen Telekom VOIP-Anschluß und einen Kabel-BW Anschluss. Zur Zeit läuft meine Pfsense immer noch in Winterzeit, und damit mein gesamtes Netzwerk.

    Was kann ich tun?



  • In der NTP Server-Konfig. (Services > NTP) das Telekom Interface hinzufügen.

    Grüße



  • Danke geht wieder