Re: Please help me about Captive Portal

  • Greeting all..

    hye, i very2 newbie in pfsense .. i just want to ask all the expert out there..  i have a problem.. my problem is, at my firewall (LAN NIC)  i have attach one linksys router which is wrt54gs.. the problem is.. when one user with a laptop loggon through the captive portal.. all the user which connect the same AP can by pass the authentication process of captive portal.. In this case, the firewall just capture the router ip address.. not the user ip address.. that why all the user in the same AP can by pass all the authentication when one user login. so, how can i overcome this sort of problem? can anyone outside there help me?

    ??? ??? ??? :'(

  • CAnn anyone there help me?? ur help are highly appreciated.. :'( :'( :-\

  • Ok i screwed up trying to merge your multiple posts into a single thread.

    As i wrote before: you have to set your Accesspoint into bridge-mode or routing only (no NAT).
    Unless you do that it just wont work.

    If you dont know how to configure your Accesspoint…. and try finding the manual.

  • but i think my AP doesn't have that sort of function…  so, do i need to upgrade my router firmware into open WRT?

  • According to the manual your AP has 5 ports:
    WAN and 4x LAN

    Ignore the WAN port and connect one of the 4 LAN ports to the pfSense.
    The LAN ports are bridged to the WLAN.

  • owh  is that so.. i need to connect the cable through Lan port nor the wan port.. thanks for the information… thank a lot.. ;D

  • yes let your linksys router behave as a switch the LAN adapter of pfsense connect to LAN port of your linksys router and configure your linksys router to have open authentication and let CP handle it. this works for me  ;D

  • I did this on a system on Saturday.

    Things to note.
    1. Make sure your LAN port on the Linksys is not using a conflicting IP to the PFSense LAN.
    2. Also remember to turn off the DHCP server on the Linksys so that it does send conflicting address to pfSense's DHCP server.

    Then it should work great.

Log in to reply