1ip vpn + squid



  • hey all and thanks to any that read this question.

    I have pfsense 2.3 latest build installed running on a dedicated machine nearly all is fine I have my main network on 192.168.1.1/24 and Wan on a PPPoE service dialling to a bridged modem.

    My issue is I also have a dedicated open vpn connection that I use for only one ip by creating a nat rule and changing the gateway for that ip allowing me to have 3 computers two showing location as my isp ip the third showing say amsterdam via vpn.

    i recently installed squid and have it running fine but when i do an ip check for the vpn machine i get two ip address? i have checked into this and tried turning off the via option in squid and turned X-Forwarded Header Mode to off but still it does not work.

    i read it may be because my vpn is not my default gateway but mu PPPoE connection is and my connection is being sent via both gateways.

    is there something i can do to prevent this in squid.conf any suggestions be helpful.

    thanks to all that make this sofware and make the internet a better place and give novices like me something to tinker with ;)



  • well i could not find anything either thanks for reading any that did.

    i worked around the issue by turning off transparent proxy and blocking http at firewall for all other networks except my own trusted and on that one i have two web browsers now one configured for squid the other not.

    so browser one is going through proxy second browser goes via VPN without leaking.

    i am going to try and configure wpad so i don't have to manually configure browsers, its not perfect but anyone finding themselves in same situation at least you can have a semi work around.

    thanks all