Squid and squidGuard are not starting



  • Hi experts, when I'm trying to "start/run" the services of squid and squidGuard they are automatically stopping. Where can I check the log to see what are the cause of the not starting/running.

    Update:

    I've checked in System Logs

    Mar 24 10:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 24 10:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 24 10:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.

    Regards,



  • Anyone encounter this? I've already reinstall the SQUID and SQUIDGUARD packages, but they kept stopping.



  • Here's my pfSense version:

    2.3.3-RELEASE-p1 (amd64)
    built on Thu Mar 09 07:17:41 CST 2017
    FreeBSD 10.3-RELEASE-p17



  • First uncheck "Keep Settings/Data"
    Go to the installed packages and remove squid
    Go to available packages and install squid pkg. Don't be update browser window before installation is complete.

    Go to the Services - Squid Proxy services and setup it.
    Next set check box to Enable and put Save button

    Write about results.



  • @kobzar:

    First uncheck "Keep Settings/Data"
    Go to the installed packages and remove squid
    Go to available packages and install squid pkg. Don't be update browser window before installation is complete.

    Go to the Services - Squid Proxy services and setup it.
    Next set check box to Enable and put Save button

    Write about results.

    Thank you for your response. But still the same. After several minutes, the services will stopped.



  • show more full squid log from start to stop point



  • I've encountered in the past where even if I uncheck to keep settings they still persist across installations.  Try going to the command line and run "squid start" to see what the errors are.  "squid -z" can also fix a bunch of errors.



  • @kobzar:

    show more full squid log from start to stop point

    Here's the log from "Status/System Logs/System/General"

    Mar 29 05:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 05:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 05:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 05:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 05:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 05:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 05:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 05:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 05:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 05:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 05:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 05:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 06:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 06:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 06:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 06:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 06:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 06:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 06:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 06:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 06:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 06:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 06:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 06:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 07:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 07:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 07:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 07:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 07:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 07:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 07:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 07:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 07:30:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 07:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 07:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 07:45:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 08:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 08:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 08:00:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 08:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Mar 29 08:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Mar 29 08:15:00 php-cgi rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Mar 29 08:27:18 sshd 73878 Accepted keyboard-interactive/pam for admin from 192.168.0.163 port 19412 ssh2
    Mar 29 08:28:50 php-fpm 72910 /index.php: Successful login for user 'admin' from: 192.168.0.163
    Mar 29 08:30:42 kernel pid 76891 (squid), uid 100: exited on signal 6
    Mar 29 08:30:51 kernel pid 35029 (squid), uid 100: exited on signal 6
    Mar 29 08:31:00 kernel pid 56749 (squid), uid 100: exited on signal 6
    Mar 29 08:31:10 kernel pid 58833 (squid), uid 100: exited on signal 6
    Mar 29 08:31:15 kernel pid 60692 (squid), uid 100: exited on signal 6
    Mar 29 08:31:22 kernel pid 62439 (squid), uid 100: exited on signal 6

    @Stewart:

    I've encountered in the past where even if I uncheck to keep settings they still persist across installations.  Try going to the command line and run "squid start" to see what the errors are.  "squid -z" can also fix a bunch of errors.

    Hi Stewart, I've tried the "squid -z" command but stuck in:

    [2.3.3-RELEASE][admin@xxx.localdomain]/root: 2017/03/29 08:31:48 kid1| Creating missing swap directories



  • go to the console and do next:
    stop squid

    cat /usr/local/etc/squid/squid.conf|grep cache_dir
    And see where is your cache dir in config file.
    Check if path is present or change path in config
    next
    rm -rf /…//.../cache and make new squid -z
    start squid


  • Banned

    
    mv /var/squid/cache /var/squid/cache.old
    squid -z
    rm -rf /var/squid/cache.old
    
    


  • Estou com o mesmo problema

    Apr 6 18:24:04 Squid_Alarm 68886 Attempting restart…
    Apr 6 18:24:04 Squid_Alarm 68723 Squid has exited. Reconfiguring filter.
    Apr 6 18:24:01 php-fpm 45253 /rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules.
    Apr 6 18:24:01 php-fpm 45253 /rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Apr 6 18:24:01 php-fpm 45253 /rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.

    Apr 6 18:24:00 check_reload_status Reloading filter
    Apr 6 18:23:59 php-fpm 14111 /pkg_edit.php: [squid] Starting a proxy monitor script
    Apr 6 18:23:49 php-fpm 14111 /pkg_edit.php: The command '/usr/local/sbin/squid -f /usr/local/etc/squid/squid.conf' returned exit code '1', the output was '2017/04/06 18:23:49| /usr/local/etc/squid/squid.conf:123 unrecognized: 'REDIRECT_CHILDREN_OPT''
    Apr 6 18:23:49 php-fpm 14111 /pkg_edit.php: [squid] Starting service…
    Apr 6 18:23:48 php-fpm 14111 /pkg_edit.php: [squid] Stopping any running proxy monitors
    Apr 6 18:23:46 php-fpm 14111 /pkg_edit.php: [squid] Starting a proxy monitor script
    Apr 6 18:23:36 php-fpm 14111 /pkg_edit.php: The command '/usr/local/sbin/squid -f /usr/local/etc/squid/squid.conf' returned exit code '1', the output was '2017/04/06 18:23:36| /usr/local/etc/squid/squid.conf:123 unrecognized: 'REDIRECT_CHILDREN_OPT''
    Apr 6 18:23:36 php-fpm 14111 /pkg_edit.php: [squid] Starting service…


  • Banned

    Read the post above!


Log in to reply