Problem with Status_Traffic_Totals Package

  • I'm having a problem with the Status_Traffic_Totals package.  I don't recall seeing this happen in the months before when I've checked my statistics, but I noticed it the other day when I went to look at my monthly totals.  My Hourly, Daily, and Top 10 Totals all appear to be fine and report data using the correct date format.  But when I check the Monthly tab, my data from the current month (March) is showing up as last month (February) with no current month (see images below)?  I've had the package installed for a while and never noticed this before, but the package also hasn't changed in some time so I don't know what is causing the issue.

    My "Daily" summary looks like:

    My "Top 10 Days" looks like:

    But my "Monthly" summary looks like:

    I first tried to "Reset Graphing Data" which wiped out all my data  :'(, but didn't fix the issue.  I then tried uninstalling the package, removing /var/db/vnstat completely, and then reinstalling the package to no avail.

    It appears the data within vnstat is correct?

    /usr/local/www: vnstat -q
                          rx      /      tx      /     total    /   estimated
     WAN (em0):
           Mar '17     X.71 GiB  /    X.17 GiB  /   X.88 GiB  /  X.00 GiB
         yesterday     X.72 GiB  /    X.28 GiB  /   X.00 GiB
             today      X.72 GiB  /  X.09 MiB  /    X.27 GiB  /    X.55 GiB

    And so forth for all my interfaces.

    I went so far as to change line 710 in status_traffic_totals.php from:

    var date = Date.UTC(,;


    var date = Date.UTC(,;

    Which lead to the following "Monthly" view:

    Which then shows 04 (April) which is a month ahead.  So one would think that "" as in the original code would show 03, but it shows 02 instead as my original "Monthly" image shows.

    It seems really odd that I would be the only person having this problem.  Does anyone have any ideas on where or what would be skewing my data off?  I can't think that I would be the only one having this problem, especially after wiping my data and starting from scratch.  But nobody else seems to have reported anything like this so I'm at a loss?

    Does anyone have any idea as to what might be happening?  Any other folks using the package seeing similar behavior?

  • I am Having the same issue. The month of March is missing  :-

  • I see the same.

    But April is now there.

  • Banned


    But April is now there.

    So it fixed itself, no? You just need to wait for a month…  ;D ;D ;D  :P :P :P

  • I wouldn't say it fixed itself.  Now that April has arrived, the monthly totals now show two entries for February and none for March.  ???

  • I have the same problem.

    March and april is missing, february is twice.
    April transfer is now added to second february.

  • I have the same issue as drinny… March showed up as February... April is showing up as April. It was a clean install in the middle of March, so I don't have the actual month of February to compare to.

Log in to reply