Acme: LetsEncrypt through proxy



  • Hi,

    I've go two pfSense installations, one has a public IP and the acme package with the pdns hook works as expected. Now the other firewall doesn't have direct internet access, updates/packages have to go through a proxy. (Which works fine as well.)

    But it seems to me that the acme package doesn't honor my proxy settings and I get errors like the following:

    [Fri Mar 24 14:20:34 CET 2017] Registering account
    [Fri Mar 24 14:21:50 CET 2017] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 7
    [Fri Mar 24 14:21:50 CET 2017] Can not connect to https://acme-v01.api.letsencrypt.org/directory to get nonce.
    

    Any ideas how I could solve this?



  •                 $env['ALL_PROXY'] = "1.2.3.4:8888";
    

    Adding the above line to acme_sh.inc in line 40 worked well for me. But since I don't know how to access global config to retrieve the system wide proxy settings, I had to hard code my proxy. Also the script should support wget as well. But this shouldn't be that big a deal for somebody used to pfsense packages. Any idea how to contact the maintainer?