Wireless weirdness



  • Hi folks,

    PROBLEM:

    When I try to talk to anything over wireless, the connection behaves funny.  Here's a typical scenario:

    In Firefox, I try to go slashdot.
    The connection is established OK, but then it just hangs there.  Browser spins waiting for data to come back.
    If I then tell Thunderbird to get mail (or, in another Firefox window, browse to another URL) – essentially, open another TCP connection -- Firefox will burp out slashdot.

    This is VERY repeatable with more than one computer (802.11b and 802.11g) connected to the WRAP via wireless.

    It feels as though some packet is being dropped and TCP is waiting for a time-out?  But that doesn't explain why opening another connection seems to clear the condition.  Or maybe there's some TCP state that's getting plugged up?

    I've taken some TCP dumps, but haven't had much luck going through the traces.

    Here's my setup:

    WRAP 1E-2
    Wistron Atheros CM9 mini-pci 802.11a/b/g card
    pfSense BETA4 is installed (although I experienced this weirdness with BETA2 as well)

    WAN is connected to my cable modem
    Wireless interface is bridged to LAN
    Wireless interface is acting as host AP
    Wireless interface configured to allow intra-BSS communication
    Wireless interface is configured for RTS/CTS
    Firewall rules allow Wireless subnet (source) to any (destination).

    Things I can do:
    *  WEP works
    *  I can get a DHCP lease when connected to LAN or wireless (or both)
    *  Can access WAN (e.g., google.com) when connected to LAN
    *  Signal strength (SNR) from NetStumbler is good: >-35dB.

    Has anyone encountered this?  Is there something obvious with configuration or firewall rules I'm missing?  I've been staring at this for weeks.

    Much thanks in advance,
    CK



  • I have the same problem with the same hardware. 
    I have one post on French forum without answer. 
    I search a solution to solve this problem.



  • I reconfigured mine to work as an access point and it seems to be working without any problems for me.



  • can it be a DNS problem ?

    run nslookup to multiple site from your client and see if you get fast response from nslookup.



  • Thanks for the suggestions.

    I don't think DNS is a problem because my local machine should cache the address after the first lookup.  This weirdness happens no matter how many times I hit the same website.

    After doing some TCP dumps, it looks as though some packets are getting dropped (I did this a while ago and don't remember exactly the circumstance).  I have a feeling large FIFO overrun errors encountered on another thread

    http://forum.pfsense.org/index.php?topic=1007.0

    have something to do with this?  I tried, as suggested in that thread, to turn off diversity and to use only the primary antenna for RX and TX.  There was no change in behavior.

    Also, I do believe I mispoke before.  My AP is in mixed b/g mode with RTS/CTS turned on.  I am only observing this when I connect with 802.11b.  802.11g seems to work more or less OK.

    Any other ideas?

    Have people tried connecting to Atheros CM9 in mixed b/g mode?

    CK



  • The CM9 does have issues with some pure B clients of older types, this is normally a issue with long/short preamble. And should be solved by getting a updated firmware for the 802.11b card. I do know that some cards have proven dificult in the past, but I don't use any pure B cards regularly anymore. I do have a notebook with a proxim goldcard, but I haven't used it for more then a year now, I might try it with pfsense if I have some spare time in the future. Your best bet would be other cards or updated firmwares.


Log in to reply