Router logs into captive portal isntead of user



  • Hey, so I set everything up on my pfsense box, I have 3 interfaces WAN, LAN and guest. My Guest interface has a different subnet to my lan and a captive portal. It works perfectly when I connect my PC via cable to the Guest interface. The portal shows up fine(there's a bug actually that doesn't allow me to set "no authentication " but other than that it works) and I log in and browse.

    However when I connect the GUEST interface into a router (lan port) with dhcp forwarder pointing pfsense, if I access my guest wifi the portal shows up fine too, but when I enter the right login credentials it redirects me to the portal screen again. My guess is that it is not allowing my wireless access point to access the portal acting as if the router was a client(which it is with a fixed ip) I added the router to the portals whitelist with confusing success, now the portal identifies my router and logs it in but the users connected to the router end up stuck in some sort of limbo on the login page where if you try to login it redirects you to a blank page So I'm stuck here, any help would be appreciated!
    EDIT: in Status–>Captive Portal my access point appears as a logged in user instead of my phone (with the credentials I entered on my phone)


  • Banned

    The router shouldn't be routing, forwarding DHCP or anything. It should be a dumb wifi - LAN bridge.



  • (IT IS SOLVED!)
    Well, that's exactly how I set it up (DD-WRT)with no dhcp and static IP on the same subnet. However, everything got fixed when I tried connecting it to other router running OpenWRT (also DHCP disabled) and problem solved! However now I'm getting issues with URL redirection, now it logs the user in but it redirects the user to a 404 not found (I set redirurl to www.google.com ).




Log in to reply