OpenVPN VIP



  • I've reached a dead end on trying to get OpenVPN to work with my VIP's. I get a block of 8 IP's assigned by my ISP, 5 of which are usable. Connection is PPPoE .

    Now, I can set up OpenVPN on my 'primary' PPPoE address, works perfecty, and I have a mail and Web servers working perfectly using a 1:1 NATs on two of the other VIP's.

    I think I have tried just about evertyhing, scanning the forum for ideas and or solutions but nothing makes it work.

    So, as it currently stands, I have OpenVPN Interface set to LocaHost.

    The VIP I want to use is set to CARP

    I believe I have both LAN and WAN rules set correctly.

    WAN rule is Source=ANY Destination=VIP address and port=1195
    LAN rule is Source=ANy Destination=LocalHost and port=1195

    It's probably something really stupid and I'm having a blonde moment.



  • Try using NAT.

    Interface WAN, Source ANY, Destination VIP, Dest. ports 1195, NAT IP 127.0.0.1, NAT Ports 1195



  • I think I already tried that… Oh well, I'll try it again.

    Actually, I've found an easier way. I've just moved something else to the IP I was trying to get the  VPN to work on, and moved the VPN back to the primary, all works now. :)

    Told you it was a blonde moment!


Log in to reply