Wie würdet ihr das machen / Wo steckt der Wurm?



  • Hallo zusammen

    Ich hatte leider die unangenehme Erfahrung machen müssen, dass sich ne C20x und pfSense nicht so mögen. 4 Tage lang unendliches grundloses neustarten, diverse vermeintlich defekte Rams, 2 Neuinstallation viele viele Nerven später, hats dann nach einem Bios Updowngrade (von 2010er auf 2012er auf neustes 2014er um dann aufs zweitneuste zurückzusatteln) gefunzt, pfSense ist stabil auf der C20X. Nur habe ich gerade das Problem, dass irgendwo sonst der Wurm drin stecken muss. eventuell, und gut denkbar, ist es etwas ganz banales, und ich übersehe es einfach. Aber wie würdet Ihr dass da machen? :

    Internet kommt per DSL an die Sunrise InternetBox, diese kann man nicht in einen Bridge Modus versetzten, und soll auch nicht, wegen der Telefonie (DECT)  nur als solche fungieren. Daran angeschlossen sollte die pfSense sein, dahinter der Switch, ein HP ProCurve 2910AL, daran dann ein TP Link WLan Acces Point und anderen LAN sachen.

    Nun irgendwie will dass bei Router - pfSenss schon nicht, woran könnte das liegen, und welche Einstellung würdet ihr nutzen?

    Freundliche Grüsse und schönes WE noch



  • Das kann man schon so machen, aber was ist eigentlich konkret das Problem und was genau hast Du probiert?



  • Zuletzt habe ich bei der InternetBox den DHCP draktiviert, und die pfSense per MAC Adresse zugeordnet. In der Hoffnung NAT Konflikte so zu beseitigen.
    Auf der pfSense habe ich dem DHCP den Bereich dann als des alleine nichts nütze, nen anderen IP Bereich zugeordnet, also 10.0.0.20
    Habe Ber gerade das Gefühl, dass ich irgendwo etwas grundlegendes falsch mache/ verstanden habe.



  • Auf der pfSense mußt Du bei der Installation ein LAN und ein WAN Interface angelegt haben. WAN verbindest Du mit der "Sunrise InternetBox", LAN mit Deinem Switch. Hast Du das so eingerichtet?

    Dann:

    • Auf dem WAN Interface fest die Adresse 192.168.1.2 zuweisen.

    • Auf dem LAN Interface kannst Du das Netzwerk 10.0.0.0/24 verwenden. Dann solltest Du der pfSense die Adresse 10.0.0.1 zuweisen. (Das ist nicht zwingend, aber sehr dringend zu empfehlen.) Die anderen Sachen im LAN bekommen dann per DHCP Adressen aus diesem Subnetz, auf der pfSense solltest Du dafür den DHCP-Server im LAN-Subnetz aktivieren / konfigurieren.



  • Ich hab das eigentlich auch so gemacht/zumindest probiert.

    Aber das zuweisen, dass müsste ich doch auf der Box machen, oder? Da ging leider nichts, aber muss mal noch weiter schauen.  Denn mein Versuch, das so zumachen, als dass ich dem Wan die statische IP zuweise hat nicht geklappt, resp. nichts gebracht.



  • Ja, natürlich solltest du die WAN IP auch über statisches Mapping konfigurieren können, aber warum sollte man einem DHCP sagen, dass er einer bestimmten Schnittstelle ein bestimmte IP zuweisen soll? Dazu brauch ich doch keinen DHCP und setze die IP gleich direkt auf der pfSense.

    So wie du deinen Aufbau beschrieben hast, hängt am internen Interface der Internet-Box nichts anderes als die pfSense. Dann deaktiviere doch den DHCP auf der Box und gib ihr eine statische IP und ebenso der pfSense, jeweils mit der richtigen Maske. Als Gateway setzt du die IP der Internet-Box.

    Wenn du von außen Verbindungen in dein LAN erlauben möchtest, musst du am WAN Interface auch den Haken bei "Block private networks" entfernen, denn die Internet-Box transferiert vermutlich eingehende Paket auf ihre interne IP.



  • Hi

    Du das will noch immer nicht funktionieren, auch wenn dass so eingestellt ist, verzweifle echt langsam.

    Hab Zwischenzeitlich die IPFire Disk eingebaut, und mit IPFire funzts, aber ich mein dass kann doch nicht sein. Hab das Gefühl, dass ich gerade den Wald vor lauter Bäume nicht sehe.



  • Wenn was nicht funktioniert, ist es immer geschickt, Du sagst, was genau nicht geht. Kannst Du z.B. überhaupt auf Deine Box über das Netzwerk zugreifen?

    Zeig mal Deine Konfiguration (Interfaces) und schreib mal auf, wie das aktuell genau verkabelt ist.


Log in to reply