[Solved] Install fails



  • Hi,
    I tried to install pfSense-CE-memstick-2.4.0-BETA-amd64, 22 April as a new fresh install and the install hangs, see attached screenshot
    I also installed FreeBSD-11.0-RELEASE-amd64-memstick and that installation went fine without any problems.
    Hardware is a Nexcom DNB120, with a Atom E3827 Processor 1.75GHz, Dual Core with 4GB of RAM
    I tried to remove the USB keyboard but it does not make any difference and the install hangs.
    Any suggestions how to resolve this install issue, is more info needed?
    ![2017-04-22 21.16.24.jpg](/public/imported_attachments/1/2017-04-22 21.16.24.jpg)
    ![2017-04-22 21.16.24.jpg_thumb](/public/imported_attachments/1/2017-04-22 21.16.24.jpg_thumb)


  • Rebel Alliance Developer Netgate

    NMI messages are hardware faults. It's not a software problem.



  • Problem solved, it was a bios setting.

    For others who may run into the same problem check for a setting in bios about emulation of usb I/O ports 64h and 60h, disabling that setting and the installation worked without problems for me.



  • fwiw: Your post was a really big deal for me when I happened across it.

    That board is what Sophos uses for their SG 105/115 UTM's.

    I have three of these that have been laying around for a couple of years, and I've never been able to get around that error.

    With my near total lack of BSD knowledge (and it appears BSD specific) I went a ways down the rabbit hole and got nowhere.

    Toggled that usb setting per your post and the install was uneventful after that.

    As a result, I now have three small pf routers that I can use for small projects instead of giving up my good hardware.

    I'm getting around 800mbps as a pure router, with a load around 10%, so it's a nic limitation.

    I should see what I can pull both aggregating and under a more real world load of packages.

    In any event, it's an order of magnitude more performant than Sophos ever was.


Log in to reply