Telekom VOIP - von manchen Anrufern nicht erreichbar



  • Hallo,
    ich habe leider das Problem, dass ich von manchen Nummern der Telekom nicht angerufen werden kann.
    Auch das raustelefonieren klappt manchmal nicht und ich muss es erneut versuchen.

    Es tritt auch auf, wenn ich mich selbst anrufe über meinen eigenen Anschluss.

    Meine Einstellungen entsprechen dem angepinnten Thread, wenn der Ruf nicht durchgeht sehe ich folgende Einträge im Log
    Apr 21 16:47:52  WANP0    <extip><meineöffentilicheip>UDP
    Apr 21 16:47:52  WANP0    <extip>:5060    <meineöffentilicheip>:5060  UDP

    Wenn ich kurz vorher raus telefoniere, würde ich vermuten, dass die Connection ja auch noch  besteht.
    Aber irgendwo scheint es zu haken, beim Anschluss handelt es sich um einen privaten FTTH-Anschluss ohne statische IP.

    Telekom Glasfasermodem => Pfsense 2.3 => Fritzbox 7490 6.83 (Nummern sind hier drauf terminiert)

    Hat sonst vielleicht noch jemand das Problem und eine Lösung dafür?
    Ich habe gerade mal testweise mir bei Placetel einen Account angelegt und diesen zusätzlich auf der Fritzbox konfiguriert, dies klappt einwandfrei, ich kann angerufen werden und ohne Verzögerung raus telefonieren.

    Ich hatte das Problem schon vorher, als ich zwischen Modem und PFsense nocht eine Fritzbox hatte (exposed Host) und hatte immer vermutet, dass es an diesem Konstrukt lag, als ich dann umgestellt habe, dass Pfsense PPPOE macht hat für ein paar Stunden alles funktioniert, dann war aber das alte Verhalten wieder da.</meineöffentilicheip></extip></meineöffentilicheip></extip>



  • @CarstenK.:

    Hallo,
    ich habe leider das Problem, dass ich von manchen Nummern der Telekom nicht angerufen werden kann.
    Auch das raustelefonieren klappt manchmal nicht und ich muss es erneut versuchen.

    Es tritt auch auf, wenn ich mich selbst anrufe über meinen eigenen Anschluss.

    Meine Einstellungen entsprechen dem angepinnten Thread, wenn der Ruf nicht durchgeht sehe ich folgende Einträge im Log
    Apr 21 16:47:52  WANP0    <extip><meineöffentilicheip>UDP
    Apr 21 16:47:52  WANP0    <extip>:5060    <meineöffentilicheip>:5060  UDP

    Wenn ich kurz vorher raus telefoniere, würde ich vermuten, dass die Connection ja auch noch  besteht.
    Aber irgendwo scheint es zu haken, beim Anschluss handelt es sich um einen privaten FTTH-Anschluss ohne statische IP.

    Telekom Glasfasermodem => Pfsense 2.3 => Fritzbox 7490 6.83 (Nummern sind hier drauf terminiert)

    Hat sonst vielleicht noch jemand das Problem und eine Lösung dafür?
    Ich habe gerade mal testweise mir bei Placetel einen Account angelegt und diesen zusätzlich auf der Fritzbox konfiguriert, dies klappt einwandfrei, ich kann angerufen werden und ohne Verzögerung raus telefonieren.

    Ich hatte das Problem schon vorher, als ich zwischen Modem und PFsense nocht eine Fritzbox hatte (exposed Host) und hatte immer vermutet, dass es an diesem Konstrukt lag, als ich dann umgestellt habe, dass Pfsense PPPOE macht hat für ein paar Stunden alles funktioniert, dann war aber das alte Verhalten wieder da.</meineöffentilicheip></extip></meineöffentilicheip></extip>

    Hi, hast du alles nach dem hier: https://forum.pfsense.org/index.php?topic=120063.0 konfiguriert?



  • Genau, daran habe ich mich orientiert.



  • Hilft ein Port Forward des SIP-Port 5060 auf die FritzBox?

    Welche Regel blockt den eingehenden Traffic? Was steht im Log, wenn das heraustelefonieren nicht geht? Wenn Du Dich selbst anrufst, schlägt das immer fehl oder nur manchmal?



  • @-flo-:

    Hilft ein Port Forward des SIP-Port 5060 auf die FritzBox?

    Leider nein, dies ändert leider nichts.

    @-flo-:

    Welche Regel blockt den eingehenden Traffic?

    Anscheined diese "Block private networks and loopback addresses" oder "Block bogon networks", beides habe ich temporär deaktiviert.
    Die Meldungen sind im Log verschwunden, das Problem ist unverändert.

    @-flo-:

    Was steht im Log, wenn das heraustelefonieren nicht geht?

    In dem System-Log leider nichts.

    @-flo-:

    Wenn Du Dich selbst anrufst, schlägt das immer fehl oder nur manchmal?

    Das schlägt immer fehl.



  • @CarstenK.:

    @-flo-:

    Hilft ein Port Forward des SIP-Port 5060 auf die FritzBox?

    Leider nein, dies ändert leider nichts.

    @-flo-:

    Welche Regel blockt den eingehenden Traffic?

    Anscheined diese "Block private networks and loopback addresses" oder "Block bogon networks", beides habe ich temporär deaktiviert.
    Die Meldungen sind im Log verschwunden, das Problem ist unverändert.

    @-flo-:

    Was steht im Log, wenn das heraustelefonieren nicht geht?

    In dem System-Log leider nichts.

    @-flo-:

    Wenn Du Dich selbst anrufst, schlägt das immer fehl oder nur manchmal?

    Das schlägt immer fehl.

    Poste mal screenshots von deinen settings…



  • Hier nochmal ein Auszug aus der Fritzbox
    Internettelefonie mit <meinenr>@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: (408)
    27.04.17
    10:36:36
    Internettelefonie mit <meinenr>@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: Server Time-out (504) [2 Meldungen seit 27.04.17 10:22:19]

    Dazu habe ich im Log der pfsense nur noch folgende EInträge (10.0.100.10) ist meine Fritzbox
    pr 27 10:47:04 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP
    Apr 27 10:44:59 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP

    Welche Settings wären interessant?</meinenr></meinenr>



  • @CarstenK.:

    Hier nochmal ein Auszug aus der Fritzbox
    Internettelefonie mit <meinenr>@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: (408)
    27.04.17
    10:36:36
    Internettelefonie mit <meinenr>@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: Server Time-out (504) [2 Meldungen seit 27.04.17 10:22:19]

    Dazu habe ich im Log der pfsense nur noch folgende EInträge (10.0.100.10) ist meine Fritzbox
    pr 27 10:47:04 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP
    Apr 27 10:44:59 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP

    Welche Settings wären interessant?</meinenr></meinenr>

    Auszug deiner Firewall Rules und NAT settings. Screenshot bitte kein copy paste.



  • @ceofreak:

    Auszug deiner Firewall Rules und NAT settings. Screenshot bitte kein copy paste.










  • @CarstenK.:

    27.04.17
    10:36:36
    […]
    Internettelefonie mit <meinenr>@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: Server Time-out (504) [2 Meldungen seit 27.04.17 10:22:19]

    Dazu habe ich im Log der pfsense nur noch folgende EInträge (10.0.100.10) ist meine Fritzbox
    pr 27 10:47:04 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP
    Apr 27 10:44:59 igb1 (1000002620)   10.0.100.10   224.0.0.1 IGMP</meinenr>

    Das hängt schonmal nicht zusammen. Die timestamps passen nicht (10:36 vs. 10:44) und IGMP hat damit nichts zu tun.



  • @-flo-:

    Das hängt schonmal nicht zusammen. Die timestamps passen nicht (10:36 vs. 10:44) und IGMP hat damit nichts zu tun.

    Ok, aber woran könnte es liegen?
    Die Einstellungen passen ja eigentlich zu der Anleitung die oben angepinnt ist.

    Oder liegt doch irgendwo auf Seiten der Telekom ein Problem vor?



  • Ist Keep alive aktiv in der Fritz Box?
    Hast du die UDP Timeouts entsprechend angepasst?
    Stun in der Fritz box aktiv? Wenn ja bitte ausmachen.



  • @flix87:

    Ist Keep alive aktiv in der Fritz Box?
    Hast du die UDP Timeouts entsprechend angepasst?
    Stun in der Fritz box aktiv? Wenn ja bitte ausmachen.

    Stun  habe ich hier nicht gefunden, der Rest sieht aus meiner Sicht gut aus.








  • Hm, die Timings sehen gut aus… Setz sie mal zum test noch etwas höher und wenns nix hilft wieder zurück (Bei unserem VOIP anbieter wird 130 benötigt)...

    Du sagst, dass das Problem nur bei Nummern aus dem Telekom Netz besteht und alle anderen Nummern durchkommen?

    Könnte das etwas mit Vectoring zu tun haben? (Hab keine Ahnung, nur ne Idee)



  • @ceofreak:

    Hm, die Timings sehen gut aus… Setz sie mal zum test noch etwas höher und wenns nix hilft wieder zurück (Bei unserem VOIP anbieter wird 130 benötigt)...

    Ich habe sie auch mal auf 130 gestellt, würde aber erwarten, dass es nicht dazu kommen sollte, da die Frittzbox ja alle 30 Sek die Verbindung aufrecht hält

    @ceofreak:

    Du sagst, dass das Problem nur bei Nummern aus dem Telekom Netz besteht und alle anderen Nummern durchkommen?

    Ja, ist bisher nur aus dem Telekomnetz aufgefallen

    @ceofreak:

    Könnte das etwas mit Vectoring zu tun haben? (Hab keine Ahnung, nur ne Idee)

    Ich dachte Vectoring würde es nur bei DSL-Anschlüssen geben, nicht bei FTTH?
    Da kennen sich aber Andere sicherlich besser aus, als ich ;)

    Bin da echt am verzweigeln, nicht weil ich es brauche, sondern weil es mich wahnsinnig macht die Ursache nicht zu finden.



  • @CarstenK.:

    @ceofreak:

    Hm, die Timings sehen gut aus… Setz sie mal zum test noch etwas höher und wenns nix hilft wieder zurück (Bei unserem VOIP anbieter wird 130 benötigt)...

    Ich habe sie auch mal auf 130 gestellt, würde aber erwarten, dass es nicht dazu kommen sollte, da die Frittzbox ja alle 30 Sek die Verbindung aufrecht hält

    @ceofreak:

    Du sagst, dass das Problem nur bei Nummern aus dem Telekom Netz besteht und alle anderen Nummern durchkommen?

    Ja, ist bisher nur aus dem Telekomnetz aufgefallen

    @ceofreak:

    Könnte das etwas mit Vectoring zu tun haben? (Hab keine Ahnung, nur ne Idee)

    Ich dachte Vectoring würde es nur bei DSL-Anschlüssen geben, nicht bei FTTH?
    Da kennen sich aber Andere sicherlich besser aus, als ich ;)

    Bin da echt am verzweigeln, nicht weil ich es brauche, sondern weil es mich wahnsinnig macht die Ursache nicht zu finden.

    Willkommen in der Welt von pfSense + Fritzbox Voip :D

    Sorry, da weiß ich grade auch nicht weiter, wenn mir noch was einfällt komm ich noch mal wieder.

    Kannst ja mal bei der Telekom anrufen, mit ganz viel (gaaaanz viel) Glück bekommst nen fähigen Techniker drann der dir evtl nen entscheidenden Tip geben kann…

    Btw, versuch einfach mal zum spaß die State Table der Firewall zu resetten, das hat bei mir schon oft das ein oder andere VOIP Problem behoben. (Diagnostic / States / Reset States)

    Viel Glück,

    Ceo



  • @flix87:

    Stun in der Fritz box aktiv? Wenn ja bitte ausmachen.

    Und auf der Firewall blockieren. Mein VoIP-Telefon macht STUN, auch wenn das abgeschaltet ist.



  • Die Telekom hat leider nichts gefunden bisher, die States habe ich auch schon ein paar mal resetet.

    Danke euch für die Tipps.



  • Ich wollte das Thema jetzt nochmal angehen, was auffällt ist, dass es bei Anrufen die nicht durchgehen folgende Meldung im Log der pfsense gibt.
    Das sieht so aus, als wenn die Fritzbox kein keepalive machen würde, wenn ich aber dann vom Handy aus anrufe klappt es sofort.

    Jan 23 08:24:16 WANP0 Default deny rule IPv4 (1000000103) 217.0.23.100 91.17.x.x UDP
    Jan 23 08:24:16 WANP0 Default deny rule IPv4 (1000000103) 217.0.23.100:5060 91.17.x.x:5060 UDP

    Das Thema macht mir echt graue Haare



  • Ich hatte mal ein ähnliches Symtom. Dabei stellte sich heraus das nur die Anrufe von Telekomkunden mit IP Technik nicht durchkamen. Telekom Alt / Mobilfunk war kein Problem

    Ich  bekomme es nicht mehr genau hin aber ich meine mich erinnern zu können das ich damals nach diesem Guide vorgegangen bin

    https://doc.pfsense.org/index.php/VoIP_Configuration

    Als ich dann den Haken bei "disable scrub" wieder weggenommen habe ging es.

    Bitte nur als Hinweis verstehen da ich das leider für mich nicht sauber dokumentiert hatte.

    Vielleicht hilft es aber



  • @hbauer:

    https://doc.pfsense.org/index.php/VoIP_Configuration

    Als ich dann den Haken bei "disable scrub" wieder weggenommen habe ging es.

    Das scheint es gewesen zu sein, es geht.
    Ganz lieben Dank, super!!!



  • freut mich wenn es half



  • Funktioniert bei Euch auch die HD Telefonie, G722?
    Bei mir klappt das nur eingehend…
    Hardware ist ne Fritzbox 7390 mit AVM Dect Phones.



  • Hmm ich habe in dem letzten Verbindungsbericht nur G.711 und G.711u gesehen. Dies Hat man eigentlich auch zwischendurch die Möglichkeit die Anrufe inkl. verwendeter Kodierung sich anzeigen zu lassen?



  • Guten Abend.

    Ich bin gerade ein wenig am verzweifeln da ich das gleiche Problem habe welches hier beschrieben wird.
    Sitze nun schon ca.3 Wochen an dem Problem und habe Asterisk am Wochenende auf PJSIP umgestellt.
    Trotzdem kommen manche anrufe der Telekom oder Vodafone nicht durch.
    Wobei ich sagen muss, das einige Telefonanrufe (Telekom IP) durchkommen.

    Der Haken bei "Firewall Scrub deaktivieren" ist nicht gesetzt.
    Wenn ich diesen setze geht garnichts mehr, ist das normal?

    Hat hier vielleicht noch jemand einen Tipp?



  • Ich wollte mich einmal zurückmelden.
    Es funktioniert.
    Habe asterisk auf TCP umgestellt und schon ging es.

    Christian



  • @CarstenK.:

    Die Lösung war das Häkchen bei "Disable Firewall Scrub Disables the PF scrubbing option which can sometimes interfere with NFS traffic." zu entfernen.

    Seitdem läuft es bei mir auch einwandfrei!

    Besten Dank!


Log in to reply