SQUID + BRIDGE interface (Troubles)



  • Hello 2 all.
    I have a problem with bridge and squid on my device.
    INFO:

    WatchGuard x750e with pfsense 2.3.3_1

    My network settings:

    sk0 (WAN)

    BRIDGE0 (sk3, msk0, msk1, msk2, msk3) - "LANET"
    BRIDGE1 (sk1, sk2) - "TN"

    Firewall:
    For all devises added rule "Allow from any to any" for each interface and bridges.

    DHCP:
    "LANET" - 10.20.30.0/24
    "TN" - 10.11.12.0/24

    NAT:
    For 10.20.30.0/24 allowed NAT to WAN.

    The problem:
    When i configure transparent proxy and select "TN" interface (in each field on squid configure page) - all working fine.
    Client got ip address, use www so on…

    But when i do the same, but select "LANET" interface - internet doesn't working. 
    acceess.log is clean. No one rows were added.

    Where is my mistake? What is wrong? The setting and configuration is simple and the same in both variants.

    Advise please.



  • no ideas?


  • Banned

    Does not not work, simple. See https://redmine.pfsense.org/issues/1620



  • I couldn't understand how this can help?
    I read all by your link but not find resolve for this issue.
    As i say before, i have two bridges and one of them working.
    All settings the same.
    Different only network
    "LANET" - 10.20.30.0/24
    "TN" - 10.11.12.0/24
    and interfaces

    BRIDGE0 (sk3, msk0, msk1, msk2, msk3) - "LANET"
    BRIDGE1 (sk1, sk2) - "TN"

    All another - the same.


  • Banned

    @kobzar:

    I couldn't understand how this can help?

    I'm saying you that it simply has never worked with Squid package. Read the bug, go test the suggested changes. Other than that, stop doing bridging if you want transparent Squid on pfSense itself. (Other than that, I have no idea what are you intending to do with a bridge on WAN and running Squid on WAN - WTF really.)



  • I DONT use bridge with WAN (sk0) interface.
    And i couldn't understand why its work with bridge1 correct.


  • Banned



  • I found solution with WPAD at the moment.
    So, lets see how its work.


Log in to reply