Captive Portal authentication redirect not working with IE 11



  • HI All,

    We had a VM which installed pfsense and would like to use Captive portal for all guests.
    I'm looked at some pages in this forum and also follow the Troubleshoot page by https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting , but still can't make Captive portal work with IE 11.

    my case,

    we just using a Captive portal  with unauthentication  . just want the guest to know the policy when they using our network.
    but , I tested in IE it won't redirect(if I set after authentication redirection URL it Work!! but we would like to show the page which the guest want to go, such as their company page.) , and will stop and show your page can't not reach. but if you open the new tag in IE it can browser to the internet.
    Using Chrome and Firefox CP will redirect the page work find and fast even it is https such as YouTube, google , yahoo , apple…etc...

    I'm tested using DNS forwarder and DNS resolver also have the same problem. Firewall rules is setting PASS for the CP  interface .
    I dont know it is a bug or only my setting problem.

    anyone know what the problem in my case ?

    Thanks

    Sorry for my English is bad .



  • @bear410hk:

    I dont know it is a bug or only my setting problem.
    anyone know what the problem in my case ?

    Thousands, no billions of people are using the captive portal every day.
    Another use number are those using IE11.
    So, that rules out the non-capabilities of pfSense : it works (for years now).

    The only thing we - and you as it seems - don't know is : how did you set it up ?
    For example : Using the build in logging page : it will work - you made your own and something is broken … so ;)
    Tell us more, and we might be able what you should or shouldn't do.


Log in to reply