Hyper-V hosted PFSense with Windows AD, DNS and DHCP - WAN dropping under use



  • Hi All,

    I have PFSense setup on Hyper-V and it has been running excellent for the past year and a half with hardly any disconnections.

    I have changed the use of the machine it was hosted on and opted for a fresh install.

    I have BT Infinity FTTC at home and my setup is set to bthomehub@btbroadband.com and password as "bt".

    When ever I run an ookla speedtest it starts out at about 49mbs and then drops eventually down to 0 and then when I look at the gateway monitor ip it is showing as DOWN,  after a few moments the connection comes back for a short period and then the same happens again.

    I am getting the same wired and wireless and running from the BT Open Reach modem straight to the BT Homehub 5 works fine with no issues.

    It is a fresh install and I have not changed anything else.  I have tried legacy adaptors and normal adaptors within Hyper-V but get the same result.

    Can anyone help please or give me a few things to try tonight.



  • Have you tried with different drivers versions for physical nic that you are using for Wan?
    IE the driver in the host operating system?

    In worst case it might even be worth to try another nic (If it doesn't do anything else it will rule out the nic as the cause)


Log in to reply