VPN issue to reach a subnet



  • Hi all,

    After lots of tries, I haven't found a solution. I'm setting up an openvpn server. My network is :

    • LAN interface : 10.50.99.16
    • OPT1 : 10.8.0.1

    OpenVPN :

    • IPv4 Tunnel Network : 10.8.0.0/24
    • IPv4 Local network(s) : 10.50.99.0/24

    My routing table as a client is :

    10.8.0.0    255.255.255.0        On-link          10.8.0.2    311
            10.8.0.2  255.255.255.255        On-link          10.8.0.2    311
            10.8.0.255  255.255.255.255        On-link          10.8.0.2    311
            255.255.255.255  255.255.255.255        On-link          10.8.0.2    311
            224.0.0.0        240.0.0.0        On-link          10.8.0.2    311

    In my case, I can ping my own gateway (10.8.0.1) but I can't reach the subnet 10.50.99.0/24. Do you have any idea?

    There is no NAT, everything is open in the lan rules.

    Thank you



  • Please post the whole routing table.



  • @Scurz:

    Hi all,

    After lots of tries, I haven't found a solution. I'm setting up an openvpn server. My network is :

    • LAN interface : 10.50.99.16
    • OPT1 : 10.8.0.1

    OpenVPN :

    • IPv4 Tunnel Network : 10.8.0.0/24
    • IPv4 Local network(s) : 10.50.99.0/24

    My routing table as a client is :

    10.8.0.0    255.255.255.0        On-link          10.8.0.2    311
            10.8.0.2  255.255.255.255        On-link          10.8.0.2    311
            10.8.0.255  255.255.255.255        On-link          10.8.0.2    311
            255.255.255.255  255.255.255.255        On-link          10.8.0.2    311
            224.0.0.0        240.0.0.0        On-link          10.8.0.2    311

    In my case, I can ping my own gateway (10.8.0.1) but I can't reach the subnet 10.50.99.0/24. Do you have any idea?

    There is no NAT, everything is open in the lan rules.

    Thank you

    You need a separate subnet for the "tunnel network"; one that doesn't conflict with your OPT1 subnet.


Log in to reply