32 bit config restore on 64 bit full cant access lan



  • i have been running a alix nanobsd 32 bit, i just got a apu2c4 so first i tried to backup alix config, rename the vr0/vr1 to igb0/igb1 in the config so on restoring interfaces dont mess up, then installed 2.4 64bit full serial on the msata of the apu2c4 and then after first boot restored the alix config.

    After this i see the wan and vpn etc all connected and even the lan ip as i had in the alix in the serial console but i just cant open pfsense gui, nor any of the lan PCs have internet access, it seems dhcp server get messed up so stops giving out ips but even setting a manual ip in PC i cant access pfsense or the internet.

    i also tried 2.3.4 but its same on that also, the config restores but there is something different on 64bit compared to the 32bit nanobsd.

    any1 come across this issue?


  • Banned

    Did this many times without any problem. (The only thing you lost is the RRD data, cannot move those between  32/64bits.)



  • my bad, i just figured out the vr0 on alix was next to the power cable whereas in the apu its flipped, now igb0 is next to serial port



  • alix nanobsd 32 bit, i just got a apu2c4

    You could edit the XML backup file and change the vr(x) against the new Ethernet port names, that´s it!


Log in to reply