Web Safety + Squid



  • Всем привет. Заинтересовала тема https://docs.diladele.com/tutorials/filtering_https_traffic_squid_pfsense/diladele.html и попытался проделать тоже самое. На моменте запуска /bin/tcsh prerequisites.sh получил ошибку:

    
    Fetching py27-setuptools27-19.2.txz: 100%  231 KiB 236.5kB/s    00:01
    Installing py27-setuptools27-19.2...
    pkg: py27-setuptools27-19.2 conflicts with py27-setuptools-32.1.0_1 (installs files into the same place).  Problematic file: /usr/local/lib/python2.7/site-packages/easy-install.pth.dist
    
    Failed to install the following 1 package(s): http://pkg.freebsd.org/freebsd:10:x86:64/release_3/All/py27-setuptools27-19.2.txz
    Fetching py27-sqlite3-2.7.11_7.txz: 100%   28 KiB  29.1kB/s    00:01
    Installing py27-sqlite3-2.7.11_7...
    pkg: Missing dependency 'py27-setuptools27'
    
    Failed to install the following 1 package(s): http://pkg.freebsd.org/freebsd:10:x86:64/release_3/All/py27-sqlite3-2.7.11_7.txz
    Fetching py27-django18-1.8.10.txz: 100%    3 MiB   3.1MB/s    00:01
    Installing py27-django18-1.8.10...
    pkg: Missing dependency 'py27-sqlite3'
    
    Failed to install the following 1 package(s): http://pkg.freebsd.org/freebsd:10:x86:64/release_3/All/py27-django18-1.8.10.txz
    Fetching py27-pytz-2015.7,1.txz: 100%  132 KiB 135.5kB/s    00:01
    Installing py27-pytz-2015.7,1...
    pkg: Missing dependency 'py27-setuptools27'
    
    Failed to install the following 1 package(s): http://pkg.freebsd.org/freebsd:10:x86:64/release_3/All/py27-pytz-2015.7,1.txz
    
    

    и я так понимаю setuptools стоит более новый и что лучше ничего не трогать, но возможно кто нибудь знает как побороть данную ситуацию? Возможно стоит указать в prerequisites.sh другие версии пакетов? (пробовал искать под py27-setuptools-32.1.0_1, но поиски не увенчались успехом).
    Заранее спасибо.



  • Доброе.
    Вещь неплохая , но платная. Если только переустанавливать периодически.

    P.s. И с праздником Победы всех!


Log in to reply