[SOLVED] OpenVPN Client Export - Empty link in Version 2.3.4 ?



  • Hello everyone,

    Last week I upgraded to version 2.3.4-RELEASE and also updated all of our installed packages, so openvpn-client-export has been updated to version 1.4.3.

    OpenVPN is still operating like normal when connecting remotely, but I came across the following issue:

    Yesterday I added a new VPN user - went to the User Manager and created user with the certificate. Then I went to VPN –> OpenVPN --> OpenVPN Clients tab... but it's empty (https://<ip address="">/vpn_openvpn_client.php). So I did some research online until I found the link to the page that was used in the previous version (https://<ip address="">/vpn_openvpn_export.php).

    Once I manually changed the page link in the browser, the page loads quickly. I scrolled down to the OpenVPN Client section, and the complete list of users is there (including the new user I created a few minutes before)! It still has the buttons on the right-hand side to export the client configuration I needed. I downloaded the configuration file & installed it on the user's laptop. When I ran OpenVPN through my phone's hotspot to test the connection, everything seems to work like normal.  :)

    So my question is why version 2.3.4 doesn't show any OpenVPN Clients, but manually going to the old page shows all of them in the OpenVPN Client section?


    Unrelated to the OpenVPN question... but since I upgraded to 2.3.4, the list of Installed Packages won't load in Package Manager, even after a few minutes. However, if I click on the Available Packages tab, that tab loads quickly, then I can click back on the list of Installed Packages and it loads quickly as well... just figured I'd mention it in case others run into the same issue.</ip></ip>



  • After re-installation of the packet the menu was shown again on my pfSense GUI.



  • Worked perfectly! I reinstalled the openvpn-client-export package, and it added back the Export tab and Shared Key Export tab.

    Thank you!  :D



  • That's a +1 for me.

    Had a new 2.3.2 install late last week (only cd I had available), got it working with OpenVPN and the Client Export pkg.
    After all had settled for a few days, let it do an auto-update to 2.3.4.
    Worked fine, but I noticed the Client Export pkg didn't show in the OpenVPN subsection.

    The pkg was listed as installed already, so I forced a reinstall and all is well.



  • Well, reinstalling the openvpn-client-export package added back the Export tabs, but I found out it also changed our client export files.

    I downloaded a new config file & found that the two bottom lines in the old version's client config file:
          tls-auth pfSense-udp-<port>-<username>-tls.key 1
          ns-cert-type server

    Were replaced with the following line:
          remote-cert-tls server

    I updated my config file (instead of right-clicking and selecting "Connect", select "Edit Config") and now VPN connects like normal.

    I updated the package to 1.4.5 this morning, and it still connects fine after making the change above.  Now I just have to update the config file on the other laptops.</username></port>


Log in to reply