Fritzbox hinter pfSense mit Vodafone VoIP



  • Hallo,

    nachdem ich lange herumprobiert habe, dachte ich mir, ich teile mal meine funktionierende VoIP Konfiguration (pfSense benutzt Draytek Vigor 130 als Modem (Bridge-Modus)) für VoIP über eine dahinter hängende Fritzbox:

    Grundeinstellungen in der Fritzbox wie hier: Zur Einstellung der Fritzbox habe ich erstmal diese Anleitung befolgt: https://avm.de/service/fritzbox/fritzbox-7580/wissensdatenbank/publication/show/177_Mit-FRITZ-Box-ueber-anderen-Router-telefonieren/

    Aber bitte Port-Forwarding in pfSense nur für die Ports 7078 bis 7109 auf die Fritzbox einstellen. NICHT Port 5060. In der Fritzbox das Intervall, in dem sie die Portweiterleitung aktiv halten soll, auf 30 Sek. einstellen (unter Telefonie -> Eigene Rufnummern -> Anschlusseinstellungen ->Verbindungseinstellungen ändern).

    Dann wie hier https://forum.pfsense.org/index.php?topic=120063.0 beschrieben Hybrid Outbound NAT rule generation aktivieren, eine Outbound-NAT-Regel erstellen und die Timeouts für alle 3 UDP-Einträge auf 35s stellen.

    So sollte es funktionieren.

    Wenn abgehende Anrufen funktionieren, aber bei eingehenden das Telefon nicht klingelt, fehlt die Outbound-NAT-Regel. Wenn die Outbound-NAT-Regel existiert, kann es sein, dass die Fritzbox gebootet werden muss. Bei mir läuft es nicht (sofort - Langzeittests habe ich noch nicht gemacht), wenn pfSense neu gebootet wird, die Fritzbox aber durchläuft.

    Wenn beide Anrufe funktionieren, aber Ihr nichts hört (wohl aber gehört werdet), fehlt das Port-Forwarding der Ports 7078 bis 7109.

    Ich hoffe, das hilft jemandem!
    ![Screen Shot 2017-05-12 at 10.49.35.png](/public/imported_attachments/1/Screen Shot 2017-05-12 at 10.49.35.png)
    ![Screen Shot 2017-05-12 at 10.49.35.png_thumb](/public/imported_attachments/1/Screen Shot 2017-05-12 at 10.49.35.png_thumb)
    [Screen Shot 2017-05-12 at 11.02.38.png](/public/imported_attachments/1/Screen Shot 2017-05-12 at 11.02.38.png)



  • Servus,

    ich musste bisher keine Portforwarding eingehend einstellen. Ausschließlich die outbound static port-option ist notwendig, damit VOIP mit FB als TK-Anlage funktioniert

    Hattest geprüft, ob es nur mit static port port?

    Grüße,
    Thorsten



  • Ja, ich hatte erst nur den Port-Forward à la AVM. Damit konnte ich rauswählen und mich unterhalten, aber es klingelte nicht bei eingehenden Anrufen. Dann habe ich alle Port Forwards wieder gelöscht und den static outbound eingetragen. Nun gingen Anrufe rein wie raus, aber ich hörte nichts. Hier klappt's nur in der beschriebenen Kombo.

    Wirklich blöd ist, dass ich die Fritte nach jedem Boot von pfSense auch neu booten muss. Das lässt sich nur sehr frickelig automatisieren… Hoffen wir mal, dass das nur selten und nicht ungeplant vorkommen wird.

    Grüße!



  • Bei Dir stimmt irgendetwas nicht. Die Fritte registriert ihre SIP-Konten alle Weile selbst neu. Da muss nichts neugestartet werden.

    Ich würde folgendes versuchen:

    1. static port outbound tcp / udp  (ich habe das mit der xxx.xxx.xxx.xxx/32 IP der Fritte als Source eingetragen)
    2. SIP Konten auf der Fritte nur mit Registrar und ohne STUN eintragen.
    3. NAT keep alive auf 30 Sekunden.

    Wenn Vodafone nicht vollständig als viele andere läuft, muss das eigentlich gehen. State Reset auf der pfS nach Änderungen am NAT nicht vergessen.



  • Ok, das ist ja im Prinzip, wie ich es habe, nur ohne den zusätzlichen Portforward.

    Gerade nochmal versucht:

    • Portforward raus, NAT apply, State Reset - Telefon klingelt nicht mehr bei eingehendem Anruf. Rausrufen geht.

    • Neustart Fritzbox: Telefon klingelt wieder bei eingehendem Anruf. Ich kann die andere Seite immer noch nicht hören.

    • Portforward wieder rein, NAT apply, kein State Reset - Schon kann ich die "Gegenseite" wieder am Telefon hören.

    Ich weiß nicht, warum. Aber so sehen die Abhängigkeiten hier mit Vodafone und der 7580er Fritte aus.

    ![NAT Outbound.png](/public/imported_attachments/1/NAT Outbound.png)
    ![NAT Outbound.png_thumb](/public/imported_attachments/1/NAT Outbound.png_thumb)
    ![NAT Port Forward.png](/public/imported_attachments/1/NAT Port Forward.png)
    ![NAT Port Forward.png_thumb](/public/imported_attachments/1/NAT Port Forward.png_thumb)
    ![Eigene Rufnummern.png](/public/imported_attachments/1/Eigene Rufnummern.png)
    ![Eigene Rufnummern.png_thumb](/public/imported_attachments/1/Eigene Rufnummern.png_thumb)



  • Servus,
    dein Outbound NAT hat keinen static Port. So sieht das bei mir aus:




  • :-\

    Stimmt, der ist beim Hin- und Hertesten irgendwann mal draußen geblieben. Aber: Ohne die NAT-Regel höre ich trotzdem nix, auch wenn ich das wieder reinmache. Keine Ahnung, warum.



  • Faszinierend, dass die eigentlich identische Technik unterschiedlich reagiert. Naja, Hauptsache Du kannst Dialoge und nicht nur Monologe führen  ;D


Log in to reply