Problemas con VLAN'S



  • Hola.

    Tengo problemas al tratar de usar VLANS con mi pfsense. Tengo el siguiente escenario

    ![](http://Pfsense 1)

    Se siguieron todas las recomendaciones y se configuro de la siguiente manera:

    ![](http://Pfsense 2)
    ![](http://Pfsense 3)
    ![](http://Pfsense 4)

    Se esta usando un switch cisco 3750 y la configuración es la siguiente:

    ![](http://Pfsense 5)

    Al realizar las pruebas desde el puerto descrito en la imagen no obtiene DHCP. Se coloca una IP fija y tampoco llega al Pfsense.

    Agradezco me ayuden a entender el problema, ya que presento el mismo problema en una maquina en producción.

    ![Pfsense 1.PNG](/public/imported_attachments/1/Pfsense 1.PNG)
    ![Pfsense 1.PNG_thumb](/public/imported_attachments/1/Pfsense 1.PNG_thumb)
    ![Pfsense 2.PNG](/public/imported_attachments/1/Pfsense 2.PNG)
    ![Pfsense 2.PNG_thumb](/public/imported_attachments/1/Pfsense 2.PNG_thumb)
    ![Pfsense 3.PNG](/public/imported_attachments/1/Pfsense 3.PNG)
    ![Pfsense 3.PNG_thumb](/public/imported_attachments/1/Pfsense 3.PNG_thumb)
    ![Pfsense 4.PNG](/public/imported_attachments/1/Pfsense 4.PNG)
    ![Pfsense 4.PNG_thumb](/public/imported_attachments/1/Pfsense 4.PNG_thumb)
    ![Pfsense 5.PNG](/public/imported_attachments/1/Pfsense 5.PNG)
    ![Pfsense 5.PNG_thumb](/public/imported_attachments/1/Pfsense 5.PNG_thumb)


  • Rebel Alliance

    El puerto del SW que va al pfSense debe ser un "Trunk" y además (como tienes solo 2 interfaces de red en el pfSense) te ahorras problemas si la LAN también la signas a una VLAN, ya que de lo contrario el puerto del SW al que conectas el pfSense lo tendrás que configura de manera que "acepte" los paquetes sin TAG (LAN) y los paquetes con TAG (VLAN 2 / OPT1).

    LAN –> VLAN 10

    OPT1 --> VLAN 20

    SW  (Puerto que conectas al pfSense) --> Trunk (VLAN10, VLAN20)

    En el "apartado" Documentación encuentras algunos ejemplos



  • Hola muchas gracias me sirvió mucho tu ayuda pude dar solución.


  • Rebel Alliance

    De Nada !  ;)

    Por Favor "edita" el Título de tu primer Post y Agrega: [Resuelto]



  • Hola,

    Me acabaron de surgir 2 dudas:

    1. las pruebas en producción funcionaron de manera correcta, sin embargo al realizar las pruebas en el ambiente de pruebas de virtualbox no me funciona. Es la configuración del virtualbox?. En ese caso que se debe hacer?.

    2. Voy a realizar conexión remota por medio de OPEN VPN, es necesario que la WAN se encuentre en un VLAN o se debe realizar otro procedimiento para poder ver mis VLANS por OPEN VPN.

    Agradezco su ayuda y que pena por volver a preguntar.



  • Con lo del VirtualBox, depende de como asignaras las tarjetas de red.  En mi caso, creo las otras tarjetas como internas y las podes nombrar como VLAN1, VLAN2, etc.  Luego, cuando queras probarlas con alguna máquina virtual cliente, simplemente seleccionas la tarjeta de red interna a la que necesites probar.

    Con lo de la VPN, supongo que es una sola configuración ya que pfSense, es quien administra toda la red.  La VPN debe estar configurada y simplemente es un puente.  No sé si debes o se pude redirigir a toda la red o a una VLAN específica.



  • Hola,

    coloque una de las dos tarjetas como red interna y aun así continua fallando. Creo que por ahora voy a probar Vmware y con respecto a la VPN voy a probar un puente.
    De todas maneras si conocen otra solución seria bueno analizar y probar.

    Gracias



  • ¿No crees que sería más facil explicar que te está fallando? En VirtualBox, la WAN debe estar como puente o NAT, pero si tus pruebas son para conectarte externamente, debe ser puente.  Las LAN o VLAN son las que deben estar como RedInterna y le pones a cada una un nombre diferente.

    Eso hago yo y me funciona, pero si no explicas que es lo que no te funciona, entonces nada vas a lograr ya que VMware y otros programas de máquinas virtuales trabajan de forma muy similar.



  • en las siguientes imágenes se puede ver la configuración de las tarjetas de red

    ![](http://Pfsense 6)
    ![](http://Pfsense 7)

    se configuro las VLAN's en la maquina en virtualbox y se utilizo el switch

    ![](http://Pfsense 8)

    Cabe recordar que el mismo escenario en producción me esta funcionando perfectamente.

    Sin embargo me gustaría lograr poder montar este escenario en virtualbox.

    Ya probé colocando la interfaz que van a las VLAN's como Red interna y no funciona.

    ![Pfsense 6.PNG](/public/imported_attachments/1/Pfsense 6.PNG)
    ![Pfsense 6.PNG_thumb](/public/imported_attachments/1/Pfsense 6.PNG_thumb)
    ![Pfsense 7.PNG](/public/imported_attachments/1/Pfsense 7.PNG)
    ![Pfsense 7.PNG_thumb](/public/imported_attachments/1/Pfsense 7.PNG_thumb)
    ![Pfsense 8.jpg](/public/imported_attachments/1/Pfsense 8.jpg)
    ![Pfsense 8.jpg_thumb](/public/imported_attachments/1/Pfsense 8.jpg_thumb)


  • Rebel Alliance

    Realiza una "captura de paquetes" para ver si "VirtualBox" está "Tagueando"

    O como prueba Rápida, "permite" el "modo promiscuo" en los adaptadores de red del VB



  • Vamos a ver y aclarar unos puntos. ¿Qué es Virtualbox? Un programa para crear máquinas virtuales, por lo tanto si queres un escenario para conectarlos a un switch, no funcionaría lo que estas haciendo.  El switch debe ser virtual y por lo tanto NO deberías usar un switch real ya que el equipo donde está el virtualbox, debería tener tantas tarjetas físicas de red como VLAN vayas a configurar.

    En ese caso, lo que podrías hacer es utilizar un switch virtual con el program de Cisco Packet Tracer (pago) o GNS3 (libre).  Con eso simulas el switch en VirtualBox y logras lo que necesitas.


  • Rebel Alliance

    Aclaremos "otro punto" ;)

    El pfSense "Real" del compañero tiene 2 Adaptadores de Red.

    El pfSense "Virtual" del compañero también, y la PC en la que lo está "corriendo" también tiene 2 adaptadores de Red…

    • Adaptador 1: Intel I219-V

    • Adaptador 2: Realtek PCIe GBE

    Por lo que no debería tener problemas "simulando" su Red (Incluso conectandola a un Switch).



  • Bueno mientras hago las pruebas que me pidió ptt, hay un tema que me preocupa mas y es la conexión de OPENVPN con las VLAN's del pfsense.

    Hago la configuración normal y todo funciona. Me conecto al pfsense ingreso, sin embargo cuando me voy a conectar a un equipo o al switch de esa vlan no me puedo conectar.

    Hice un puente (bridge) entre la interfaz de OPENVPN y la interfaz de una de las VLAN pero aun así sigo si poder acceder.



  • Hola,

    Ya pude dar solución al tema de la conexión. Lo que sucedía era que para poder acceder a toda la red de VLAN, me toca usar un usuario administrador. Se hicieron los cambios y todo esta funcionando perfectamente en produccion.

    Con respecto al tema de virtualbox no he podido tomar las evidencias.