OpenVPN interface up but gateway down



  • Hi,

    I'm trying to setup ExpressVPN on my PFsense router.

    I've followed the following steps:
    https://www.expressvpn.com/support/vpn-setup/pfsense-with-expressvpn-openvpn/#additional

    This was a very good tutorial and seemed up to date.

    However, now that I have followed all the steps, I can not access the internet through this VPN.

    On the Dashboard, the interface is up and I have an ipaddress.
    When I go to Status > OpenVPN it shows that the VPN is connected and up.

    However on the dashboard, the VPN_DHCP has an ipaddress that but it shows this as offline.
    Loss is at 100%.

    When I have the VPN running and my rules for internet traffic through it, I have no access to the internet.

    I've looked through the instructions a few times. Does anyone have any other ideas?



  • These are some screenshots for a clearer picture.

    ![Screen Shot 2017-05-21 at 4.01.29 pm.png](/public/imported_attachments/1/Screen Shot 2017-05-21 at 4.01.29 pm.png)
    ![Screen Shot 2017-05-21 at 4.01.29 pm.png_thumb](/public/imported_attachments/1/Screen Shot 2017-05-21 at 4.01.29 pm.png_thumb)
    ![Screen Shot 2017-05-21 at 4.02.19 pm.png](/public/imported_attachments/1/Screen Shot 2017-05-21 at 4.02.19 pm.png)
    ![Screen Shot 2017-05-21 at 4.02.19 pm.png_thumb](/public/imported_attachments/1/Screen Shot 2017-05-21 at 4.02.19 pm.png_thumb)



  • I tried to search for my post and found this one instead: https://forum.pfsense.org/index.php?topic=129576.msg718034#msg718034


  • Netgate

    You almost certainly do not need DHCP enabled on the OpenVPN assigned interface no matter what that doc says. Enable the interface and set both IPv4 and IPv6 to None.

    It is common to be unable to ping the other side of an OpenVPN connection. Either set gateway monitoring to none on that gateway or set something outside like 8.8.8.8 to ping.

    Post your policy routing (LAN) rules and your outbound NAT for the VPN interface. Probably one of those two things is not correct.



  • Thank you for your help Derelict.

    I have now disabled the DHCP on the VPN.
    I also didn't know that there was a way to change the monitoring ip address. I have now done this too.

    I also needed to add "comp-lzo" like sneakking suggests in the previous post.
    (https://forum.pfsense.org/index.php?topic=129576.msg718034#msg718034)

    Now everything is working.