Changed HTTP Login option to HTTPS ….locked out Help --- SOLVED



  • Had just setup an internal CA to import to my pc.

    Went and changed the setting to HTTPS and then saved.

    Kicked me out and cant get back in

    ERR INVALID CERT.

    Am I correct in that I forgot to import the cert I created to my local pc and install it?

    If so, where to from here?

    Dont think I have a serial cable or connection on my laptop….

    Thanks in advance

    Thomas



  • Use the IP address and accept/continue passed the cert warning.



  • Thanks.

    No option for that. Just comes up with this.




  • Please don't make me spoon feed.  Investigate at least a little bit.

    Several clickables on the page.  Perhaps one of them is what's needed.



  • Hit the Advanced link at the bottom.  There should be an option to proceed anyway.  Do that.  Sign in.  Here's a link that does a reasonable job of telling you how to import that certificate (just in case you haven't seen one):

    https://www.reddit.com/r/PFSENSE/comments/5nqhzn/cant_add_pfsense_cert_to_chrome/



  • There is no option under the advanced section. I know how to install the certificate, but stupidly thought that once I went to the login IP it would give me the option to install it from there.

    Thanks for the info but relates to if the cert had been exported first…?

    Here is an expanded section of the advanced.

    Also I did not export the certificate before leaving pfsense admin. So I am taking it there is no work around after reading this.




  • Use console to restore a previous config.
    Might also try other browsers with IP address.



  • Yep, found a post on here re a patch. Tried couple of other browsers Firefox and Opera.

    They worked. But just once.

    No access to console. No cable.

    So did a reinstall and sorted it correctly this time.



  • @thomasbredman:

    No access to console. No cable.

    Normally, you don't need a special cable.
    First thing to do when you take possession a 'system' : (whatever system : your router, the fridge, tv-set, etc etc ) : activate ssh access. Because this is the 'real' admin interface ;)
    Other explication : when you modify something on your main door, check-out FIRST your secret back-door (the same ssh access).

    Btw : when you use something like this https://www.netgate.com/products/sg-1000.html I wouldn't use it before i has this special cable …. (locking myself out, well .... I know .... seen that - been there)