Squid Reverse proxy HTTPS separate subdomains without wildcard SSL



  • hello, I am in the middle of implementing a reverse proxy to make a few disparate internal sites available on the public Internet and SSL secure it.  3 of the sites already connect via HTTPS internally.  The fourth website is running only on HTTP.  I setup a let's encrypt Acme client on my pfsense firewall and was able to get Squid reverse proxy to use it.  I was able to get one of the HTTPS internal web services working using the following URI format:
    https://sub-domain.domain.com/service

    Another of the HTTPS internal web services and the HTTP website seem to hiccup when using the above URI format.  When navigating in their sites the absolute URL links are overwriting my URI to: 
    https://sub-domain.domain.com/sub-containter
    when it should be configured this way:
    https://sub-domain.domain.com/service/sub-containter

    I was hoping to be able to get around this problem by using the separate subdomains for each of the 4 sites instead of a /service sub directory.  the URI format would then look like this:

    https://sub-domain2.domain.com

    I created a Cname record on my public DNS for sub-domain2.domain.com and pointed it to sub-domain.domain.com.  now i seem to be able to get there but i do see that i have a SSL mismatch.  Let's Encrypt does not support SSL wildcards.  I would like to stick with Let's Encrypt.  Is it possible to request that Squid reverse proxy for pfsense be configured such that we can override the SSL certificates listed in the "General - Squid Reverse HTTPS Settings" menu with the appropriate subdomain SSL in the "mappings - group name" menu?  this would allow me to continue using Let's encrypt and not have to worry about a Wildcard SSL.