NordVPN random drops



  • Hi y'all, I am seeing frequent(maybe 5 times a day) drops on my pfsense router connected to NordVPN, This is so annoying that the VPN is almost useless for me. I've tried several different nord servers and they all give me same result. I've manged to capture some logs and I'm attaching the logs here. Hope some one can help me with this.

    
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:44 openvpn[82205]: TUN READ [0]
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 WRITE [88] to [AF_INET]181.215.110.153:1194: P_DATA_V2 kid=1 DATA len=87
    <29>Jun 6 14:18:29 openvpn[82205]: TUN READ [40]
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 WRITE [88] to [AF_INET]181.215.110.153:1194: P_DATA_V2 kid=1 DATA len=87
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 READ [1349] from [AF_INET]181.215.110.153:1194: P_DATA_V1 kid=1 DATA len=1348
    <29>Jun 6 14:18:29 openvpn[82205]: TUN WRITE [1296]
    <29>Jun 6 14:18:29 openvpn[82205]: TUN READ [40]
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 WRITE [88] to [AF_INET]181.215.110.153:1194: P_DATA_V2 kid=1 DATA len=87
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 READ [1349] from [AF_INET]181.215.110.153:1194: P_DATA_V1 kid=1 DATA len=1348
    <29>Jun 6 14:18:29 openvpn[82205]: TUN WRITE [1296]
    <29>Jun 6 14:18:29 openvpn[82205]: TUN READ [40]
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 WRITE [88] to [AF_INET]181.215.110.153:1194: P_DATA_V2 kid=1 DATA len=87
    <29>Jun 6 14:18:29 openvpn[82205]: UDPv4 READ [1349] from [AF_INET]181.215.110.153:1194: P_DATA_V1 kid=1 DATA len=1348
    <29>Jun 6 14:18:29 openvpn[82205]: TUN WRITE [1296]
    <29>Jun 6 14:18:29 openvpn[82205]: TUN READ [40]
    

    It looks like sth happened b/t 14:18:29 and 14:18:44 but I have no idea what was it. After that I just keep getting "TUN READ 0" until I reset the OpenVPN connection. However, the OpenVPN status page still shows "connected". BTW, I'm on 2.3.4-RELEASE


Log in to reply