Solved - Avahi won't start



  • I'm runing pfSense

    2.4.0-BETA (amd64)
    built on Mon May 29 08:10:16 CDT 2017
    FreeBSD 11.0-RELEASE-p10

    And would like to utilize avahi , as my phones and AppleTv's are on different fw interfaces.

    I have installed avahi via the "packages menu" , and can see it in the services ment , but it won't start.

    It buzzes (thinks) a little , but then shows the "Red dot again"  , if trying to start in Services

    Any hints ?

    TIA
    /Bingo

    Ps: Is it recommendable to upgrade to the newest (daily) Beta often ??



  • Did you configure avahi? Just starting the service from services menu wont do much good if it aint configured first.

    As for updating, if you need to run it in a 'production' environment then updating daily isnt the best idea imho.. If your experiencing problems and suspect they might be fixed by looking at github commit messages, or redmine tickets then of-course a update can be tried. Though do make sure to have a backup plan if it fails to upgrade or stops working all-together.. It is after-all BETA software, and things that were working before do break sometimes..

    On the other hand if you want to help test new features or confirm and report bugs and bugfixes on redmine, then upgrading often is a good thing to do :).



  • Thank you for taking your time to ansver.

    No i didn't configure anything , besides from the "GUI"

    I did try to start it via the CLI ,but it seems like it complains about Dbus , witch seems to be installed as a package , but misses dependancies , like some NSS-??? stuff.

    I'm a pfSense/FreeBSD beginner , but knows linux. And can find my way around a commandline & vi.

    I would have hoped that avahi was "prod ready" , as it was available as a package from the GUI install system.

    I did find a hint about manually installing
    http://www.alexforencich.com/wiki/en/freebsd/installing_avahi

    But would like to use the "official package" if possible.

    /Bingo



  • Not sure what you did/didnt do, but i went in the webgui to the services\avahi menu option.
    -Checked the box "Enable Avahi Bonjour/Zeroconf proxy."
    -Make sure Enable IPv4 and/or Enable IPv6 is checked.
    -And press save.
    For me it then automatically starts avahi on todays pfSense 2.4b snapshot "built on Wed Jun 07 09:27:01 CDT 2017 ".

    I do have a bunch of other packages installed, and my testmachine has been running for a while so it might have pulled in dependencies by one of the other packages perhaps.. Anyhow it 'should' work.

    If your still having problems posting the exact error message if any might help.. 'something like NSS-??' i cant help with, you need to do 'something' to solve that  ;)..



  • I just upgraded to today's snapshot too.

    2.4.0-BETA (amd64)
    built on Wed Jun 07 09:27:01 CDT 2017
    FreeBSD 11.0-RELEASE-p10

    It seems to have fixed avahi

    /root: ps aux | grep ava
    avahi      54058   0.0  0.1  29896  4128  -  I    22:11    0:00.12 avahi-daemon
    root       96242   0.0  0.0  14700  2408  0  S+   22:12    0:00.00 grep ava
    
    

    The daemon runs now  :)

    By just upgrading

    Thanx for helping out

    /Bingo


Log in to reply