VMware Remote Console gets frozen randomly…



  • Hi everyone,

    I've got the following issue regarding my homelab, using pfSense 2.3.4:

    My setup is the following:

    • 2x DL380 G7's running several VM's. (both HP images 6.0u3)

    • vCenter 6.5b

    • pfSense being hosted by one of the above hosts.

    Networking:

    • VLAN10: My network for end-users with laptops/phones/tablets.

    • VLAN11: Network for all my (virtual) servers including vCenter, and ESX.

    At this moment pfSense allows ALL traffic between VLAN11 and 10.

    My problem is the following:

    • If I connect to my vCenter using it's management IP within VLAN11 I can connect, which is fine. I can set up HTML5 (web) consoles to all my VM's which is all good.

    • If I connect to a VM using the VMRC that is being hosted by one of the ESXi machines in VLAN11 I get random freezes when there are animations (scrolling, browsing folders) on the screen.

    However if I try to connect to my hosts on their management IP's in VLAN10 (no routing needed here) I experience no freezes at all. I tried running Wireshark and I see some connection resets going on, when my issue occurs. However I am not certain on how to fix this.
    This is getting very annoying since I am not able to use VMRC's at all now when needing to configure something.

    I've tried to run Wireshark regarding my issue and this is the output I get every time I run into this issue:
    https://i.imgur.com/rDgLmmK.png

    Does anyone got any idea about this? I had a old Sophos XG VM lying around and booted up that once, to check if the issue still persisted and it didn't at all. So this seems a pfSense issue somehow. And yes, all VM's have the latest VMware Tools installed!
    Thanks in advance!



  • Just an update:

    I've reinstalled a completely new virtual machine and my issue keeps persisting…



  • Anyone at all being able to shine a light on this issue?

    I've reinstalled pfSense from scratch multiple times right now, tried all sorts of network adapters within VMware.

    None have helped, and it's getting really troublesome in a homelab right now. I've tried Sophos XG and the issue doesn't persist in that system, but some functionality is key in my pfSense VM…



  • What if you power off or disconnect one of the esxi machines? Do you still have the same error?



  • Yes! I even reinstalled both of the hosts (and their datastores)!

    Even on 2.4.0 the issue still persists!


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy