Teamspeak



  • I have a teamspeak server behind my pfsense and I can't get it to work. The server has a static ip of 192.168.1.104. I have comcast cable and when I plug it into my linksys it gets one IP, but my pfsense gets a different ip. The modem's internal ip is 192.168.1.1.

    I set up a rule in nat like this..
    WAN
    interface adress
    TCT/UDP

    8765
    8770
    192.168.1.104
    8765
    description
    Teamspeak

    I had it auto setup a firewall rule too. I have tried everything I can think of and can't get it to work.

    Additional Information.
    I have some screen shots attached of the NAT forwarding rule that I set up.  I turned on Static Port in the nat aswell.

    I have an older Linksys router that I used to use, and when I have that connected I have a different external IP than I do with the pfsense router.

    My network is as follows.

    Cable Modem >> PFSense >> Switch >> Computers

    and PFSense is getting the IP by DHCP.

    I am not a very advanced user but I am trying to learn what everything is doing.  so far everyone has worked except this.

    Thanks

    second picture.
    http://img87.imageshack.us/my.php?image=twogi5.jpg





  • Please start over with your first post and include the relevant pieces of information:
    http://forum.pfsense.org/index.php/topic,7001.0.html

    (linksys? different ip? layout of your networKk? screenshot of rule? which subnet where? etc.)



  • Edited first post to have more information.



  • The rules look good.
    What do you need a port-range for?
    For a client to connect you just need to open a single port.

    The other port used by the Teamspeak server is for managing-purposes only and should not be opened up to the world.

    When you connect your pfSense you SHOULD gt a different IP than your linksys router.
    After all they have different MAC's and they each request an IP from the DHCP from your provider.

    You dont say what's not working.
    Did you enable NAT-reflection?



  • Hi, Sorry for the long delay.

    What is not working is when I connect via a teamspeak client to my external IP address it gets an error.  If I use a computer on my network and go directly to the servers IP..192.168.1.104:8767 it works fine.

    I went to System>Advanced, and I unchecked the box that said Disable NAT Reflection and Saved it and tried again.  It still didn't work.

    I went into the rule and made it a singular port.  It also didn't work.

    Any other idea's why port forwarding isn't working?

    Thanks for all your help.


Log in to reply