PfBlocker not blocking IP Range in Top 20 IP List



  • So,
    We are running PfSense 2.3.2 Release-p1 (AMD64)
    We are running PfBlockerNG 2.1.1_4

    One of our SNORT logs shows that a user tried to contact an IP in Ukraine (we reside in the US):
    /var/log/snort/snort_vmx051006/alert.1498064056:06/21/17-11:21:01.490440 ,1,2404627,4660,"ET CNC Ransomware Tracker Reported CnC Server UDP group 114",UDP,OUR_IP_ADDRESS,3120,46.174.242.171,15129,28386,A Network Trojan was Detected,1,
    So the IP in question is: 46.174.242.171

    I have Ukraine as a blocked country in PfBlockerNG (picked on the Top 20 list). PfBlockerNG >> GeoIP >> Top 20 >> Ukraine
    The country list shows that IP range being blocked:
    cd /var/db/aliastables
    cat pfB_Top_v4.txt | grep 46.174 | more
    46.174.8.0/21
    46.174.48.0/21
    46.174.80.0/20
    46.174.104.0/21
    46.174.112.0/21
    46.174.192.0/21
    46.174.248.0/21
    46.174.40.0/21
    46.174.64.0/21
    46.174.120.0/21
    46.174.160.0/21
    46.174.216.0/21
    46.174.240.0/21

    Our PfBlockerNG General Settings for Interface/Rules Config is:
    Inbound Firewall Rules >> Block (all WAN interfaces)
    Outbound Firewall Rules >> Reject (all WAN Interfaces)

    Why did PfBlockerNG not block that IP? Its surely within the range shown as blocked in the Top 20 list. Am I missing something?
    Based on the settings, and the IP List shown in PfBlocker IP List from Top 20, it should have blocked it.


  • Moderator

    Did you configure "Deny InBound" or "Deny Outbound"?  To block that you would have to have rules on your Outbound interfaces…

    Also just a comment that you don't need to cat -> grep...    Just   ```
    grep "^46.174." *.txt


Log in to reply