Rescue me from a Beta update crash?



  • I'm a beginner and bound to make a lot of mistakes or go down the wrong path. I'm keen to support the 2.4 beta development and test run builds in my non critical home setup.

    I was having problems with the WAN configuration. My pfsense has open VPN enabled. I played around with settings to restore the connection then got the Beta update message. I invoked the update (which I think downloaded, but then the WAN connection got permanently broken and no packages could get downloaded and installed. As I understand it, packages always have to be re-installed after a kernel update?

    From then on pfsense was stuffed, I couldn't restore my WAN connection to internet, no dashboard was available and I'm stuck in a 'download packages' loop with no way out I could find. OK so I thought I could go backwards to my saved xml config file, but I should have realized that might not work because of the new update. In the end I had to do a complete re-install and setup. Perhaps there was another way I didn't find? Although this happened with my beta update, it could also have happened updating from a previous stable release?

    Are there any answers? Something simple like a check for internet connectivity first  would be re-assuring, otherwise can a working image for the previous (working) version, complete with packages be saved and recovered? Commercial routers have this backward 'get out of jail' option in mirrored rom for a configured image.  Extra hard disc space in a pfsense box is cheap or there are usb ports to save disc images and network connectivity to access backup storage media.

    I haven't found a way to save and restore a backup of a pfsense install as a disc image from the webgui? But I'm going to try using an Acronis boot stick. O.K. If you have Acronis TI home for Windows, create the standalone bootable recovery on a flash stick and pop this in your pfsense box along with a clean FAT32 blank stick (I used 16gb). Reboot the pfsense box to the Acronis memory stick (set as first boot in BIOS). Create your first compressed disc image of the pfsense drive, subsequent backups will be incremental. I don't have much on my pfsense box yet and the TI image came out at 250Mb compressed. To recover, repeat, boot into the Acronis stick pointing to the saved .tib backup file of your freeBSD disc image with packages which should be restored sector by sector. It would be so nice to do this from the pfsense webgui.

    If I get this problem again - webgui to LAN ok, internet down and pfsense stuck in a 'download packages' loop, what should I have done? Thanks



  • Look at  "Status/Services" and make sure you have no services not running.



  • Thanks, I'll do that.

    I've been researching ways to backup a pfsense installation as a clone disc image and it isn't easy. There was a mistake in my post because I'd backed up a flash drive 250Mb instead of the pfsense hard drive when the actual backup size without free space is 1.2Gb for a virgin install and 4Gb plus with packages, caches and logs backed up. Once I discovered my mistake I tried again. The only true backup is one which backs up then a restored disc image runs without errors or crashes.  I only found 2 windows GUI apps that claim to backup freeBSD format - Clonezilla and Acronis True Image.  I started with the 2.4 beta and Clonezilla wouldn't even see the hard drive(?) Acronis 2012 wouldn't see the freeBSD drive either. However, Acronis TI 2016 does see the pfsense hard drive as 3 partitions when run as the ISO on a bootable pendrive. I had limited success trying to recover from the 2.4 beta backup clone with pfsense stalling during boot.

    I then installed pfsense 2.3.4 stable, repeated the backup of 2 partitions as 'copy sectors' but exclude free space and successfully restored from the backup .tib image I'd saved on a 16Gb pen drive. Acronis 2016 has options to save to a local (usb drive), a hard drive on the home network or a NAS drive. I was curious about this but I'm now pretty certain Acronis TI uses its own drivers with the NIC interface and is completely detached from drivers runing pfsense. It must do this to be able to write back the saved drive image.

    I need to go further installing pfsense packages to see if I can still get a perfect backup of a pfsense hard drive across the LAN.  If it works, an Acronis 2016  local backup/restore can be done offline independent of an internet connection for the download and integration of packages using the built in backup xml file. For the moment I'm reverting back to 2.3.4 amd 64 stable version, although I miss the keyboard 'choose and test' built into 2.4 beta.

    This disc clone backup method needs more testing, but I'm cautiously optimistic I can get it to work.