Unterbrechung bei Telekom VOIP Verbindung



  • Hallo,

    ich habe einen sehr ärgerlichen Fehler. Ich betreibe eine Agfeo-Telefonanlage hinter einer pfsense.
    Ich kann wunderbar über mehrer SIP-Kanäle telefonieren und Faxen, nur bei längeren Telefonaten wird nach ca. 10min die Verbindung getrennt.

    Ich habe bereits die Telefonanlage ausgetauscht. doch der Fehler bleibt.

    Gibt es in der pfsense vielleicht einen Timeout wenn die Verbindung zu lange besteht?

    Kann mir jemand einen Tip geben?

    Danke



  • Servus,
    die Angaben sind etwas dürftig. Wie hast Du die Anbindung der Anlage realisiert? Ist es eine ES mit der aktuellsten Firmware? Ist die pfS bis auf ggf. static port outbound NAT in der Standardkonfiguration?

    Grüße



  • Hallo

    es ist ein ES-Anlage 628IT mit der aktuellen Firmware 1.12b. Das Problem hatte ich aber auch schon mit anderer Firmware und mit einer anderen ES Anlage 522.
    Bild folgt



  • Anbei das Bild




  • Haste das mal probiert?

    Set Conservative state table optimization - pf's default UDP timeouts are too low for some VoIP services. If your phones mostly work, but randomly disconnect, set "Firewall Optimization Options" to Conservative under System -> Advanced.

    Gruß
    Matthias



  • Hmmm. Eigentlich sollte das genügen. Ich mach das mit einer ES516 und das läuft gut. Sind die Probleme ständig reproduzierbar da? Die table optimiziation kann in der Tat dafür verantwortlich sein. Hast Du ne statische IP? Wenn nein, bekommst du ggf. Probleme mit den States nach einem IP-Wechsel. Hatte ich schon.

    Dreh den UDP-Timeout mal hoch : https://forum.pfsense.org/index.php?topic=120063.0



  • Hallo,

    ich habe eine statische IP, die Unterbrechungen sind immer bei längeren Gesprächen, über 8min, wenn meine Frau telefoniert, ich hatte es nur ein paar mal.
    Habe die UDP-Timeouts angepasst, vorher waren die blank.

    Christian



  • @be1001:

    Hallo,

    die Unterbrechungen sind immer bei längeren Gesprächen, über 8min, wenn meine Frau telefoniert

    Äh. Das ist doch ein wünschenswerter Zustand  ??? ;D



  • Ich hatte auch das Problem. Bei mir war die Lösung in der sip Config der Telefonanlage:

    "session-timers=refuse"



  • @power_matz:

    "session-timers=refuse"

    Ja daran liegt es wahrscheinlich, es müssten dann aber genau 15 Minuten sein.



  • Hallo,

    wo stelle ich das den ein finde den Eintrag weder in der Agfeo ES628IT noch in der Pfsense.

    Christian



  • Hat mit der PFSense nix zu tun. Das stellst Du in der Agfeo ein. Muss irgendwo bei den allgemeinen SIP Einstellungen sein.
    Habe keine Agfeo, keine Ahnung.