Snort won't boot anymore with the pfsense 2.3.4-RELEASE



  • Hi,

    I have now this error and I can't start the service snort anymore :

    Jun 26 07:58:00 pfSense SnortStartup[1637]: Snort START for WAN(41684_re0)…
    Jun 26 07:58:01 pfSense snort[1968]: FATAL ERROR: The dynamic detection library "/usr/local/lib/snort_dynamicrules/browser-plugins.so" version 1.0 compiled with dynamic engine library version 2.6 isn't compatible with the current dynamic engine library "/usr/local/lib/snort_dynamicengine/libsf_engine.so" version 3.0.



  • Follow the instructions I give here:  https://forum.pfsense.org/index.php?topic=127764.msg731895#msg731895 to remove Snort, clean up the older shared-object libraries and reinstall Snort.

    Bill