Why use "Transparent HTTP Proxy" option



  • I had problems with my cameras, see https://forum.pfsense.org/index.php?topic=132651.msg729419#msg729419

    The suspect was option I used enabled "Transparent HTTP Proxy".

    When disabled - all works as expected.

    I wonder what are pros and cons of using this option?

    Thx



  • This is something that is up to you/sysadmin or company internet access rules.

    There are a lot of info about it, google for transparent proxy vs non transparent



  • @marcelloc:

    This is something that is up to you/sysadmin or company internet access rules.

    There are a lot of info about it, google for transparent proxy vs non transparent

    Wow, I hit a popular topic :). Thx @marcelloc

    I, of cause, would like to keep using transparent enabled.  However I also would like to be able to stream live video.

    So the dilemma now is - how to exclude arlo video from being scanned?
    I tried using LAN IP 192.168.90.6 and also I login to external website arlo.netgear.com, but so far no luck.

    Any suggestions ?



  • Hi All,
    I realize this topic is quite old, but I thought I'd post this here just in case someone needed it. I use squid in transparent proxy mode, and also Arlo cameras. I have found a way (though it may be temporary, we have yet to see) to get streaming from inside the firewall to work.

    Steps:

    1. Log-in to your Arlo account (arlo.netgear.com)
    2. Open developer options (F12)
    3. Click on a stream as-if you were going to watch it
      a. At this time, you'll see an error which states that you cannot load the stream due to an SSL protocol error. Write down or copy that host name.
      0_1536212797549_a1915064-f496-44b9-9b40-1e5252a0a753-image.png
    4. Open your squid general settings, and scroll down to Transparent Proxy -> Bypass Proxy for these IPs and paste the host name from above.
    5. Save your settings and test.

    This is what I did to allow streaming of video clips, and I hope it helps someone else!