Route par defaut apres connection



  • Bonjour,
    depuis un moment je seche sur un problème de route par defaut lors de ma connection OpenVPN client to site sur Pfsense.

    J'ai realiser ma connection qui fonctionne bien grace au tutoriel du site de pfsense:
    http://www.pfsense.org/mirror.php?section=tutorials/openvpn/pfsense-ovpn.pdf

    malheureusement a la fin de la connection il ne change pas la route par defaut.

    Thu Nov 06 13:49:55 2008 us=321324 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Thu Nov 06 13:49:55 2008 us=321749 Route: Waiting for TUN/TAP interface to come up…
    Thu Nov 06 13:49:56 2008 us=839729 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Thu Nov 06 13:49:56 2008 us=840036 Route: Waiting for TUN/TAP interface to come up...
    Thu Nov 06 13:49:57 2008 us=908364 TEST ROUTES: 0/0 succeeded len=2 ret=0 a=0 u/d=down
    Thu Nov 06 13:49:57 2008 us=908656 Route: Waiting for TUN/TAP interface to come up...
    Thu Nov 06 13:49:58 2008 us=971718 TEST ROUTES: 2/2 succeeded len=2 ret=1 a=0 u/d=up
    Thu Nov 06 13:49:58 2008 us=971945 route ADD 192.168.1.0 MASK 255.255.255.0 10.0.8.5
    Thu Nov 06 13:49:59 2008 us=43240 route ADD 10.0.8.0 MASK 255.255.255.0 10.0.8.5
    Thu Nov 06 13:49:59 2008 us=128495 Initialization Sequence Completed

    Ma configuration est la plus simple la meme que celle du tuto.
    A savoir

    TCP sur port 443
    dynamic IP
    adresse pool 10.0.8.0/24
    Local network 192.168.1.0/24
    BFC-BC 128
    PKI
    Les Clefs sont ok

    c'est les seul informations que j'ai renseigner coté serveur.

    Config Client :

    float
    dev tun
    dev-node OpenVpn
    proto tcp-client
    remote thomasbruyere.dyndns.org 443
    ping 10
    persist-tun
    persist-key
    tls-client
    ca ca.crt
    cert client1.crt
    key client1.key
    ns-cert-type server
    #comp-lzo
    pull
    verb 4

    Avez- vous une idée de la raison pour laquelle ma route par defaut reste sur 0.0.0.0 0.0.0.0 192.168.1.1 ??

    J'attens vos réponses merci a tous



  • n'etant pas 100 % le meilleur je peut au moin aider !!!

    pour les test je t'invite a utiliser UDP comme protocol…..

    TCP a un system pour empecher la perte de paquet... mais quand tu utilise TCP avec openVPN il fait

    TCP (openVPN) sur TPC (ton internet)

    donc il y a de la redondance....(si l'un des 2 TCP n'est pas bien recu, il se renvoie.... et ca continue comme ca !!!)

    pour moi mes 3 dernier ligne sont

    Fri Feb 06 11:19:59 2009 C:\WINDOWS\system32\route.exe ADD 10.2.0.0 MASK 255.255.255.0 10.2.1.5
    Fri Feb 06 11:19:59 2009 C:\WINDOWS\system32\route.exe ADD 10.2.1.0 MASK 255.255.255.0 10.2.1.5
    Fri Feb 06 11:20:00 2009 Initialization Sequence Completed

    et toi ces

    Thu Nov 06 13:49:58 2008 us=971945 route ADD 192.168.1.0 MASK 255.255.255.0 10.0.8.5
    Thu Nov 06 13:49:59 2008 us=43240 route ADD 10.0.8.0 MASK 255.255.255.0 10.0.8.5
    Thu Nov 06 13:49:59 2008 us=128495 Initialization Sequence Completed

    la seul difference ces le c:\windows\system32\ que tu n'a pas.

    a tu fait de srecherche ???

    sinon pour le reste (fichier config)

    float
    dev tun
    dev-node OpenVpn                    theoriquement ces juste pour dire quel nom ton NIC doit avoir
    proto tcp-client
    remote thomasbruyere.dyndns.org 443    tu a juste l'address internet avec                                    l                                          e port ??? a tu l'ip a place
    ping 10
    persist-tun
    persist-key
    tls-client
    ca ca.crt
    cert client1.crt
    key client1.key
    ns-cert-type server
    #comp-lzo
    pull
    verb 4

    le mien est

    tls-client
    client
    dev tun
    proto udp
    tun-mtu 1500
    remote 142.217.136.249 1194
    #remote 10.0.3.254 1194
    ca pmfca.crt
    key arkys.key
    cert arkys.crt
    cipher AES-256-CBC
    comp-lzo
    verb 3
    ns-cert-type server
    float
    route-method exe
    route-delay 2
    ping 10

    il y a quelque difference. je crois pas que cela affecte completement ta connection (avis d'un pro si possible) mais cela sont des supposition. apres un 2ieme regard je crois que cela se situe au niveau de

    route-method exe
    route-delay 2

    ces 2 commande que j'ai et toi non….. tu pourais les ajouter et tester svp !!!!

    revien vite voir si ca marche


Locked