Client connection to 224.0.0.22



  • Hi!

    Just want to know if its a normal practice to allow connection to destination like this 224.0.0.22?

    And also,  how to do we allow client's connection to time servers?  to sync time.

    Sorry newbie question.

    TIA!

    ast



  • That address is a local network multicast for IGMP.  It's non-routable, so it shouldn't be going through your firewall.  Also, if those clients are using an external NTP server, pfSense should normally pass it.  If a local server, then pfSense shouldn't be involved.



  • @JKnott:

    That address is a local network multicast for IGMP.  It's non-routable, so it shouldn't be going through your firewall.  Also, if those clients are using an external NTP server, pfSense should normally pass it.  If a local server, then pfSense shouldn't be involved.

    Its being block by my Pfsense, can't seem to find which rule is blocking the connection.



  • You'll have to provide your rules.  However, I have no problem using NTP behind pfSense.  Also, pfSense can be configured as an NTP server, so the client NTP requests don't have to pass through the firewall.



  • @JKnott:

    You'll have to provide your rules.  However, I have no problem using NTP behind pfSense.  Also, pfSense can be configured as an NTP server, so the client NTP requests don't have to pass through the firewall.

    I was able to configure my Pfsense's NTP server, but I don't know if client's traffic of NTP is pointing to the right port.



  • Check the client's configuration.  It will say in there.  With Windows, you access it through the clock.  On Linux, it's a separate setting that depends on the disto.  Some devices can be assigned a NTP server via DHCP.

    BTW, how do you know that pfSense is blocking NTP?



  • @JKnott:

    Check the client's configuration.  It will say in there.  With Windows, you access it through the clock.  On Linux, it's a separate setting that depends on the disto.  Some devices can be assigned a NTP server via DHCP.

    BTW, how do you know that pfSense is blocking NTP?

    Hi!

    I'm really thankful for your reply!  Pardon me if you think my reply are not spot on, anyway, the reason why i said that pfsense is blocking NTP connect of clients is because I saw on my firewall log theres a red X mark from the client's ip to 224.0.0.22, 224.1.1.1 and other similar ip's.



  • ????

    Normally, a NTP client contacts the NTP server directly via a unicast IP address.  For example, the server time.nrc.ca has an IP address of 132.246.11.229.  While it is possible to use multicast for NTP, it's on address 224.0.1.1.  Are you really using mulitcast?

    I suggest you take a step back and look at what you really have.  See what the computers are configured to use. By default, Windows uses a Microsoft time server, but that can be changed.  You can also use the one I listed, but you may want one that's closer to home.

    Check out http://www.pool.ntp.org/en/ to find a pool server and try that.

    To check/set NTP on Windows 10:
    Right click on the clock
    Select Adjust date/time
    Click on Additional date, time & regional settings
    Click on Date and Time
    On Internet Time tab, click on Change Settings
    Select Synchronize with an Internet time server and check or enter the server in the box
    Click on Update now

    If it says it was successful, NTP is working.