Can't add Cert



  • I'm getting the following error while attempting to add a cert

    PureVPN
    The submitted private key does not match the submitted certificate data.

    I've already talked with their support and tried fresh files ca.crt, wdc.

    Nothing seems to work.  Working with 2.40 Beta.

    Thanks for your time and attention,
    ![pfsense cert.PNG](/public/imported_attachments/1/pfsense cert.PNG)
    ![pfsense cert.PNG_thumb](/public/imported_attachments/1/pfsense cert.PNG_thumb)


  • Rebel Alliance Global Moderator

    So you own their CA?  You would not have the private key of a CA unless you actually could sign off on certs from this CA.. Which I HIGHLY doubt they would be giving you ;)



  • Duh, makes perfect sense….  I just removed the private key and it worked.

    Thanks,


  • Rebel Alliance Global Moderator

    Just looked at their instructions - not sure what their point of trying to get you to put the key in for the CA.. They don't have a clue ;)  That is the key they are using for the tls auth - its right in their config..

    
    client
    dev tun
    proto udp
    remote vlau-us1-ovpn-udp.pointtoserver.com 53
    persist-key
    persist-tun
    ca ca.crt
    tls-auth Wdc.key 1
    cipher AES-256-CBC
    comp-lzo
    verb 1
    mute 20
    route-method exe
    route-delay 2
    route 0.0.0.0 0.0.0.0
    auth-user-pass
    auth-retry interact
    explicit-exit-notify 2
    ifconfig-nowarn
    auth-nocache
    
    

    So clearly its not the CA private key ;)