SOLVED - Lots of rrd: illegal attempt to update using time xx



  • I'm not sure if this is a 2.4.0-Beta problem (or general (mis)use) , but this is where it occurs.

    On my 2'nd QOTOM-Q355G4, just installed yesterday , i see a lot of the below messages in the system.log on boot.

    
    Jul  2 11:07:53 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/wan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/wan-traffic.rrd: illegal attempt to update using time 1498986473 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 11:07:53 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/wan-packets.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/wan-packets.rrd: illegal attempt to update using time 1498986473 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 11:07:53 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-traffic.rrd: illegal attempt to update using time 1498986473 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 11:07:53 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-packets.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-packets.rrd: illegal attempt to update using time 1498986473 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 11:07:53 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/opt1-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/opt1-traffic.rrd: illegal attempt to update using time 1498986473 when last update time is 1499014324 (minimum one second step)' 
    
    Another boot
    
    Jul  2 13:36:47 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/wan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/wan-traffic.rrd: illegal attempt to update using time 1498995407 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 13:36:47 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/wan-packets.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/wan-packets.rrd: illegal attempt to update using time 1498995407 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 13:36:47 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-traffic.rrd: illegal attempt to update using time 1498995407 when last update time is 1499014324 (minimum one second step)' 
    Jul  2 13:36:47 sv-fw-01 php-cgi: rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-packets.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-packets.rrd: illegal attempt to update using time 1498995407 when last update time is 1499014324 (minimum one second step)' 
    
    

    From searching the forum it seems like rrdtool somehow have logged an update "in the future" , maybe due to me not setting the clock correct when i was configuring the Bios.

    I do not thave these errors when booting my 1'st QOTOM.

    Both are NTP Sync'ed , but the 2'nd had pfSense installed , and was booted several times yesterday wo. any connection to the internet. Ie. NO NTP Sync.

    Is there any way of "resetting" those timestamps from the future ?

    This is not much of a problem, as my 2.4.0-Beta doesn't even have the . Status->RRD selection Menu , so i don't even think i could see the graphs if i wanted.
    But it just an "eye catcher" in the boot log , that i would like to be gone.

    My QOTOM have to be connected to a HDMI Screen in order to enter the bios (read .. Wifey away from telly) , and it is harder to get a "Service window" there , than on a Cisco C6509 with a full BGP feed.

    In order to check that the PC hardware clock is having the correct date/time , i would really like to avoid having to enter the Bios.

    I'm a *BSD beginner , but searching the "web" , it seems like the below would indicate that my PC hardware clock is updated via freebsd every 1800 secs, or ??

    fw $ sysctl machdep | grep rtc
    machdep.disable_rtc_set: 0
    machdep.rtc_save_period: 1800
    
    

    Any hints would be appreciated.

    /Bingo

    Ps:
    It wasn't hard to clone the pfSense config (xml file) , from my 1'st to my 2'nd machine.
    Making the install of the 2'nd quite easy, thanx for making it so easy.



  • Solved
    Delete the *.rrd files in /var/db/rrd  , and let pfSense recreate them (on Boot) with the correct timestamp.

    At first i just "touched" the rrd files , but that didn't help. The timestamps checkked must be inside the rrd files.

    This was a user setup error , NOT a pfSense error.

    /Bingo



  • Ohh btw.

    Is there any way to see those RRD Graphs on a 2.4.0-Beta ??
    Do i miss a package ?

    I don't have any Status->RRD menu entry.

    /Bingo



  • Status > Monitoring. (toprightscreen: Settings symbol)



  • So I ran into this problem aswell.. I caused it by changing my bios date/time, and  I fixed it by deleting the rrd data files, then restoring that "area" from a backup that I did a few minutes before (i did an update from 2.4 -> 2.4.2)

    boom fixed..

    thought it should be documented.

    James