[SOLVED] Slow WebGUI and 25s RRD refresh



  • I've got slow performance navigating the UI, but the real outlier is that the widgets on the Dashboard refresh every 25s, no matter what I set it to.  This is most apparent on the Traffic Graph widget (which has timestamps), but the Gateway and CPU widgets don't update either.

    I don't think that it's a hardware issue – I've run the SMART tests and the HD checks out.  I've ripped out all of the external packages (except for openvpn-export and acme), and I've removed and tried to re-add all of the widgets, which was a painfully slow process.

    Anybody have any ideas?

    Version 2.3.4-RELEASE (amd64)
    built on Wed May 03 15:13:29 CDT 2017
    FreeBSD 10.3-RELEASE-p19
    Platform pfSense
    CPU Type Pentium(R) Dual-Core CPU E5800 @ 3.20GHz
    2 CPUs: 1 package(s) x 2 core(s)
    Uptime 9 Days 17 Hours 52 Minutes 53 Seconds
    Current date/time
    Fri Jul 7 11:12:57 PDT 2017
    DNS server(s)
    127.0.0.1
    8.8.8.8
    8.8.4.4



  • I'll also get sporadic messages in /var/log/nginx/error.log, relating to a non-existent or bad php-fpm socket.

    connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: xxx.xxx.xxx.xxx, server: , request: "POST /ifstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:

    I currently have 6 php-fpm processes configured.



  • This ended up being a few things, but mostly a failed Authentication Server (and resolution of the actual Auth Server, and route to the relevant Auth Server, and then certificates).

    A clue was the periodic 25s latency, which also corresponds to the Auth Server Timeout (and occurs when the Auth server is queried in Round Robin via DNS).

    Or that this was only affecting Remote auth'ed users, instead of those using the Local Database.


Log in to reply