Problem gelöst (E-Mail Notifications: Passwort wird nicht gespeichert!?)



  • Guten Morgen,

    ich habe unter System / Advanced /Notifications ein gmx-Konto für den Versand der E-Mail-Notifocations eingetragen. Da ich nach Drücken des Buttons "Test SMTP Settings" eine E-Mail erhalte und im Log-File der erfolgreiche Versand eingetragen ist, passt die Konfiguration. Die Konfiguration habe ich natürlich mit "Save" abgespeichert.

    Jul 14 22:59:02 php-fpm 66022 /system_advanced_notifications.php: Message sent to 1234@gmx.de OK

    Allerdings wird im System-Log-File folgendes eingetragen wenn das Log-File automatisch versandt werden soll:

    Jul 15 02:21:18 php-fpm 48860 /rc.dyndns.update: Could not send the message to 1234@gmx.de – Error: 530 Authentication required

    Für mich sieht es so aus, als würde das unter "Notification E-Mail auth password" eingetragene Passwort nicht gespeichert werden.

    Das "Email Reports"-Package habe ich auch installiert und unter Status / Email Reports / Edit Reports / Included Logs drei Logfiles für den Versand ausgewählt. Der Button "Send now" hat offenbar keine Funktion. Es gibt keinen Eintrag im Log-File, dass das Log-File versendet werden würde.

    Kann doch nicht so schwer sein, dass ich regelmäßig Log-Files erhalte?

    Grüsse

    Ralf



  • Guten Morgen,

    ich bitte um eure Hilfe. Ich habe keine Idee mehr woran es liegen könnte, dass pfSense keine Notifications versendet bzw. warum im System-Log folgender Eintrag steht:

    /rc.dyndns.update: Could not send the message to abc-abc@gmx.de – Error: 535 Authentication credentials invalid

    Ich habe extra einen neuen Account bei gmx angelegt. Beim Passwort des E-Mail-Accounts wird auf Sonderzeichen verzichtet, nur Zahlen und Buchstaben verwendet. Die Test-Mail wird erfolgreich versendet. Bei aufgetrenen Ereignissen, die eigentlich per E-Mail versendet werden sollen, kommt jedoch jedesmal obige Fehlermeldung. Ich weiss nicht mehr woran es liegen könnte. Ist es ein Fehler der pfSense-Version 2.3.4?

    Ich bin am Verzweifeln.

    Grüsse

    Ralf



  • Hallo,

    ich kann das nicht bestätigen. Habe meine GMX-Daten gespeichert und der Mailversand funktioniert auch noch nach einem Neustart.

    Dumme Frage, aber…
    @raaalf:

    ich habe unter System / Advanced /Notifications ein gmx-Konto für den Versand der E-Mail-Notifocations eingetragen. Da ich nach Drücken des Buttons "Test SMTP Settings" eine E-Mail erhalte und im Log-File der erfolgreiche Versand eingetragen ist, passt die Konfiguration. Die Konfiguration habe ich natürlich mit "Save" abgespeichert.

    hast du das genau in dieser Reihenfolge gemacht? Wenn ja, versuch es mal anders rum, erst Daten eingeben, dann speichern, dann "Test SMTP Settings".

    Grüße



  • Hallo viragomann,

    die andere, von der pfSense-Doku abweichende Variante, habe ich noch nicht ausprobiert. Werde ich am Wochenende ausprobieren, wenn ich wieder Zugriff auf die pfSense habe. Ich danke Dir für den Tipp und die Info, dass der Versand der E-Mail-Notifications bei Dir funktioniert.

    Grüsse

    Ralf



  • Hallo,

    das Problem ist gelöst.

    Was die Ursache war? In Firefox popte jedesmal, wenn ich die Seite zur Konfiguration der Notification aufrief, die Frage auf, ob ich dass Passwort speichern will. Ich irgnorierte dies. Erst als ich die Option "Nie das Passwort für diese Seite speichern" wählte war schluss mit dem Problem.

    Ich gab nochmal das Passwort für den E-Mail-Versand ein und speicherte es. Jetzt bekomme ich E-Mail Notifications.

    Grüsse

    Ralf



  • Unglaublich.  :o

    Ob das Passwort bereits gespeichert ist oder nicht oder ob man bereits auf "nie speichern für diese Webseite" geklickt hat, hat nicht den geringsten Einfluss darauf, was FF an den Webserver schickt.
    ::)

    Grüße