Kleines Problem mit den ARP Tables



  • Hallo!
    ich nütze folgende Version von pfsense:  1.2-RELEASE  embedded

    ich habe auf meinem LAN Interface DHCP für einen kleinen IP Bereich aktiviert [für 2 PCs]
    alle restlichen PCs haben eine feste IP Adresse
    dann habe ich bei DHCP Server Einstellung den Hacken bei Deny Unknown Clients gesetzt
    und den Hacken bei Enable Static ARP entries ist ebenfalls gesetzt.

    dann habe ich alle 5 festen IP + MAC Adressen der jweiligen PCs eingetragen

    und die Einstellungen übernohmen

    wenn ich jetzt auf ARP Tables klicke dann zeigt er mir alle 5 PCs [mit fester Ip Adresse], obwohl keiner verbunden ist
    erst nach einem Neustart der BOX sind PCs in der Liste nicht mehr vorhanden und tauchen erst wieder auf wenn sie Online sind (so wie es sein sollte)

    da ich öfters an dem DHCP-Server rumspiele sind die ständigen Neustarts der BOX ziemlich nervig, kann man das irgendwie einfach machen?

    gruß
    good



  • Was du als Fehler beschreibst sollte "eigentlich" der Normalfall sein.
    Du schreibst dir deine ARP-table von Hand.
    –> Es gibt keine arp-lookups daher sind auch immer alle PC's in der ARP table.

    Oder habe ich jetzt etwas falsch verstanden was dein Problem ist?

    EDIT: Ah ich hab "deny unknow clients" mit "Enable Static ARP entries" verwechselt.
    Ich glaube wenn du die Einträge vornimmst, wird das vom System wie ein normaler ARP lookup betrachtet.
    Ich würde einfach mal lange genug warten bis der ARP Eintrag timeoutet.
    Das ist glaube ich im normalfall 500 Sekunden oder sowas in der Art.

    Du kannst natürlich auch von Hand die ARP-table an der Konsole flushen.



  • hallo!
    vielen dank für deine Antwort

    also warten 500sec oder 2 Tage bringt gar nichts es bleiben alle Einträge erhalten, erst nach einem Reboot sind alle Einträge weg ( bis auf die ,die aktuell mit der Box verbunden)

    wenn ich die ARP Tables per Hand Flashe (mit arp -d -a) dann sind zwar alle Einträge weg, aber alle Clienten die eine feste IP Adresse haben können sich nicht mehr mit dem Internet verbinden.

    wenn ich jetzt wieder arp -a ausführe dann spuckt er mir folgende Meldung aus
    localhost (192.168.1.62) at (incomplete) on sis0 [ethernet]  <–-- wie oben geschrieben der Client mit fester IP kann sich nicht mehr mit dem Internet verbinden

    bei den DHCP Clients funktioniert es!
    localhost (192.168.112.6) at 00:XX:XX:XX:XX:XX on sis1 [ethernet]

    hat jemand eine Ahnung woran das liegen könnte?
    und wie ich mein Problem beheben kann?

    gruß
    good

    edit:
    noch eine kleine Bemerkung

    wenn ich bei DHCP Server [LAN] auf Save klicke, dann sind alle Eintrage im ARP-Table enthalten  <–- wie in Post 1 beschrieben
    wenn ich bei DHCP Server [LAN2] auf Save klicke dann sind alle Einträge im ARP-Table vom LAN Interface weg[ und kein Client vom LAN Interface kann sich mehr verbinden] erst wieder nach reboot bzw wenn ich beim DHCP Server [LAN] wieder eine Veränderung vornehme

    ich bin völlig ratlos



  • Warum willst du den ARP Table überhaup löschen? Treten dann irgendwelche Probleme auf? Erwartest Du irgenwelche Sicherheitsprobleme in deinem Netz? Schließlich trägst du ja die Zuweisung entspr. ein, da können doch auch die Tables so bleiben wie sie sind?!

    EmL



  • ich dachte die ARP Tabels sind da, damit ich sehen kann welche Clients gerade mit der BOX verbunden sind?
    und wenn alle aufgelistet sind dann sehe ich es ja nicht

    gruß
    good



  • Das siehst Du eigentlich viel besser in der State-Liste. Einfach die IP-Addresse verfolgen. Es gibt zudem ein Package, welches die States noch besser darstellt.



  • kann man dieses Package auch auf einer embbeded Version nützen?



  • Nein. Auf embedded Geräten funktionieren die Packages sinnvollerweise nicht. Einige dieser Packages schreiben die HD voll, was einer SSD nicht so gut bekommt. Du könntest es jedoch manuel installieren.


Log in to reply